summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-05-31 08:57:51 +0200
committerSam James <sam@gentoo.org>2022-06-01 00:44:49 +0100
commit5c26e8b9cde6270ba8000c301872174601485416 (patch)
tree80ff20531a55fc6c37bb1085d5eef5aff068a33a /dev-java/commons-daemon/commons-daemon-1.3.1.ebuild
parentdev-java/jna: do not call STRIP directly (diff)
downloadgentoo-5c26e8b9cde6270ba8000c301872174601485416.tar.gz
gentoo-5c26e8b9cde6270ba8000c301872174601485416.tar.bz2
gentoo-5c26e8b9cde6270ba8000c301872174601485416.zip
dev-java/commons-daemon: do not call ar directly
Closes: https://bugs.gentoo.org/848498 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/25700 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java/commons-daemon/commons-daemon-1.3.1.ebuild')
-rw-r--r--dev-java/commons-daemon/commons-daemon-1.3.1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-java/commons-daemon/commons-daemon-1.3.1.ebuild b/dev-java/commons-daemon/commons-daemon-1.3.1.ebuild
index 7822d682f36a..f739750e8965 100644
--- a/dev-java/commons-daemon/commons-daemon-1.3.1.ebuild
+++ b/dev-java/commons-daemon/commons-daemon-1.3.1.ebuild
@@ -28,6 +28,7 @@ RDEPEND="
>=virtual/jre-1.8:*
"
+PATCHES=( "${FILESDIR}/commons-daemon-1.3.1-Make.patch" )
DOCS=( {CONTRIBUTING,README}.md {HOWTO-RELEASE,NOTICE,RELEASE-NOTES}.txt )
HTML_DOCS=( PROPOSAL.html )
@@ -42,6 +43,11 @@ JAVA_SRC_DIR="src/main/java"
# JAVA_TEST_GENTOO_CLASSPATH="junit-4"
# JAVA_TEST_SRC_DIR="src/test/java"
+src_prepare() {
+ default
+ java-pkg-2_src_prepare
+}
+
src_compile() {
java-pkg-simple_src_compile