summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-daemon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-daemon')
-rw-r--r--dev-java/commons-daemon/Manifest3
-rw-r--r--dev-java/commons-daemon/commons-daemon-1.0.15.ebuild57
-rw-r--r--dev-java/commons-daemon/commons-daemon-1.0.7.ebuild55
-rw-r--r--dev-java/commons-daemon/commons-daemon-1.0.9.ebuild56
-rw-r--r--dev-java/commons-daemon/metadata.xml5
5 files changed, 176 insertions, 0 deletions
diff --git a/dev-java/commons-daemon/Manifest b/dev-java/commons-daemon/Manifest
new file mode 100644
index 000000000000..bf43975345bf
--- /dev/null
+++ b/dev-java/commons-daemon/Manifest
@@ -0,0 +1,3 @@
+DIST commons-daemon-1.0.15-src.tar.gz 291128 SHA256 11ee57d2c6b281589c1497b2f88180553f06d5ac1560ce1841e05f89f0342432 SHA512 f20cc8796978fb09b6ecc8d99bb3c8b271b097d74c1f99b286cde213631e7f50a4104f5db2c354f9624ba8b037502d81e327c581b38253b9b216aa2172016e40 WHIRLPOOL 6b3b5f5d12fc9fd15345e71a7bf41f88605b00f9bc0ab5ab5fca3752f4bae1adf6ae6b2c3781a68b00d0609c51cb5cb2f4e399effa40f08be0c5dacc2e230d65
+DIST commons-daemon-1.0.7-src.tar.gz 233291 SHA256 cd782d29b85ac5fadc4b4cf6c3f86248cb31f258f020bd9b5479919effcea8b9 SHA512 2a6b3c94ba41e89576d7803c80a0a380cf073af34d45e7afd0e529942ab632264ee013aa91022905f62cb9cd92462b15cc81206565664f47ecac77c2d4565284 WHIRLPOOL 470dc894beba3b73553768267f5f0eb2ad8bdc419811907bbb23dcdf2f05f1ce4ce060a07ed1e4b6e26c81016e46d93c7b3712b3d5e8a10e38281e2f8e537896
+DIST commons-daemon-1.0.9-src.tar.gz 233786 SHA256 20aef955914f730209b432a0d2c7dd03384ae4b821eeee78964210046c63e040 SHA512 13bbf1a0671b29913b82116cbe44977b5eb9fecf8475a2ce0022e1639564808498b03ab6c87704c5e38661baadabc50a6d91e6847e62c8e4987e6fc0c834ed37 WHIRLPOOL a2008fb7e5f6ad2bc84b84315ef26731c5b7b307dfc6c2ba74743e6ef71f20dabc805d4bbb779ecac979ab7a3ba61414aacba55132c5abd685ca305968ce52de
diff --git a/dev-java/commons-daemon/commons-daemon-1.0.15.ebuild b/dev-java/commons-daemon/commons-daemon-1.0.15.ebuild
new file mode 100644
index 000000000000..9eb9baaede61
--- /dev/null
+++ b/dev-java/commons-daemon/commons-daemon-1.0.15.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+WANT_AUTOCONF=2.5
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils autotools java-pkg-2 java-ant-2
+
+DESCRIPTION="Tools to allow Java programs to run as UNIX daemons"
+SRC_URI="mirror://apache/commons/daemon/source/${P}-src.tar.gz"
+HOMEPAGE="http://commons.apache.org/daemon/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="kernel_linux"
+
+COMMON_DEP="kernel_linux? ( sys-libs/libcap )"
+
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4"
+
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ cd "${S}/src/native/unix" || die
+ sed -i "s/powerpc/powerpc|powerpc64/g" support/apsupport.m4 || die
+ eautoconf
+}
+
+src_configure() {
+ java-ant-2_src_configure
+ cd "${S}/src/native/unix" || die
+ default
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+ cd "${S}/src/native/unix" || die
+ default
+}
+
+src_install() {
+ dobin src/native/unix/jsvc
+ java-pkg_newjar dist/*.jar
+
+ dodoc README RELEASE-NOTES.txt *.html src/native/unix/CHANGES.txt
+ use doc && java-pkg_dohtml -r dist/docs/*
+ use examples && java-pkg_doexamples src/samples
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-daemon/commons-daemon-1.0.7.ebuild b/dev-java/commons-daemon/commons-daemon-1.0.7.ebuild
new file mode 100644
index 000000000000..cb0ff226b4ef
--- /dev/null
+++ b/dev-java/commons-daemon/commons-daemon-1.0.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+WANT_AUTOCONF=2.5
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils autotools java-pkg-2 java-ant-2
+
+DESCRIPTION="Tools to allow Java programs to run as UNIX daemons"
+SRC_URI="mirror://apache/commons/daemon/source/${P}-src.tar.gz"
+HOMEPAGE="http://commons.apache.org/daemon/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE="kernel_linux"
+
+COMMON_DEP="
+ kernel_linux? ( sys-libs/libcap )"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ cd "${S}/src/native/unix" || die
+ sed -i "s/powerpc/powerpc|powerpc64/g" support/apsupport.m4 || die
+ eautoconf
+}
+
+src_configure() {
+ java-ant-2_src_configure
+ cd "${S}/src/native/unix" || die
+ default
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+ cd "${S}/src/native/unix" || die
+ default
+}
+
+src_install() {
+ dobin src/native/unix/jsvc
+ java-pkg_newjar dist/*.jar
+
+ dodoc README RELEASE-NOTES.txt *.html src/native/unix/CHANGES.txt
+ use doc && java-pkg_dohtml -r dist/docs/*
+ use examples && java-pkg_doexamples src/samples
+ use source && java-pkg_dosrc src/java/* src/native/unix/native
+}
diff --git a/dev-java/commons-daemon/commons-daemon-1.0.9.ebuild b/dev-java/commons-daemon/commons-daemon-1.0.9.ebuild
new file mode 100644
index 000000000000..294fa0646ae8
--- /dev/null
+++ b/dev-java/commons-daemon/commons-daemon-1.0.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+WANT_AUTOCONF=2.5
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils autotools java-pkg-2 java-ant-2
+
+DESCRIPTION="Tools to allow Java programs to run as UNIX daemons"
+SRC_URI="mirror://apache/commons/daemon/source/${P}-src.tar.gz"
+HOMEPAGE="http://commons.apache.org/daemon/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="kernel_linux"
+
+COMMON_DEP="
+ kernel_linux? ( sys-libs/libcap )"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ cd "${S}/src/native/unix" || die
+ sed -i "s/powerpc/powerpc|powerpc64/g" support/apsupport.m4 || die
+ eautoconf
+}
+
+src_configure() {
+ java-ant-2_src_configure
+ cd "${S}/src/native/unix" || die
+ default
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+ cd "${S}/src/native/unix" || die
+ default
+}
+
+src_install() {
+ dobin src/native/unix/jsvc
+ java-pkg_newjar dist/*.jar
+
+ dodoc README RELEASE-NOTES.txt *.html src/native/unix/CHANGES.txt
+ use doc && java-pkg_dohtml -r dist/docs/*
+ use examples && java-pkg_doexamples src/samples
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-daemon/metadata.xml b/dev-java/commons-daemon/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-daemon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>