summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-10-06 10:01:52 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-10-10 08:39:51 +0200
commitc2ea91d73dcf7c8725f79e223d1faecb425499ba (patch)
tree81c278872a229a44b1d099da4eef81c30516b1bd /dev-java/commons-math/commons-math-3.6.1.ebuild
parentapp-text/htp: version bump. (diff)
downloadgentoo-c2ea91d73dcf7c8725f79e223d1faecb425499ba.tar.gz
gentoo-c2ea91d73dcf7c8725f79e223d1faecb425499ba.tar.bz2
gentoo-c2ea91d73dcf7c8725f79e223d1faecb425499ba.zip
dev-java/commons-math: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-java/commons-math/commons-math-3.6.1.ebuild')
-rw-r--r--dev-java/commons-math/commons-math-3.6.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/commons-math/commons-math-3.6.1.ebuild b/dev-java/commons-math/commons-math-3.6.1.ebuild
new file mode 100644
index 000000000000..5578f6ffa3a0
--- /dev/null
+++ b/dev-java/commons-math/commons-math-3.6.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN}3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="https://commons.apache.org/math/"
+SRC_URI="https://repo1.maven.org/maven2/org/apache/commons/${MY_PN}/${PV}/${MY_P}-sources.jar
+-> ${MY_P}.jar"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"