summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-07-11 21:27:23 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-24 18:51:46 +0200
commit1396565682c6fc9ddc7aae028cff8b7d73283514 (patch)
tree487ea030a7bc4ed427288c1e3583dc746dea545f /dev-java/commons-math
parentdev-java/commons-io: add missing Automatic-Module-Name (diff)
downloadgentoo-1396565682c6fc9ddc7aae028cff8b7d73283514.tar.gz
gentoo-1396565682c6fc9ddc7aae028cff8b7d73283514.tar.bz2
gentoo-1396565682c6fc9ddc7aae028cff8b7d73283514.zip
dev-java/commons-math: add missing Automatic-Module-Name
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/commons-math')
-rw-r--r--dev-java/commons-math/Manifest1
-rw-r--r--dev-java/commons-math/commons-math-3.6.1-r2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/commons-math/Manifest b/dev-java/commons-math/Manifest
index 2a4d73ad3ca0..6e97211d4920 100644
--- a/dev-java/commons-math/Manifest
+++ b/dev-java/commons-math/Manifest
@@ -1 +1,2 @@
+DIST commons-math3-3.6.1-sources.jar 2514690 BLAKE2B ce5dc1a5bdccf85aa780dd648b64c0ed78b4d5a36d15d9737f661135f4f1ec962c3c44a0c4d8fc7d12c667e62b19860cb2a47f507c8c3e6da6cce57e1b9caf54 SHA512 eab6003834c0f1b7e67eee242d33db43f85d388ac32e37caa6bd16d74340db5c189ff5c7fd112ef13b9009d2fbcf2bad6650b6e5d9124316b59493b2d07d065d
DIST commons-math3-3.6.1.jar 2514690 BLAKE2B ce5dc1a5bdccf85aa780dd648b64c0ed78b4d5a36d15d9737f661135f4f1ec962c3c44a0c4d8fc7d12c667e62b19860cb2a47f507c8c3e6da6cce57e1b9caf54 SHA512 eab6003834c0f1b7e67eee242d33db43f85d388ac32e37caa6bd16d74340db5c189ff5c7fd112ef13b9009d2fbcf2bad6650b6e5d9124316b59493b2d07d065d
diff --git a/dev-java/commons-math/commons-math-3.6.1-r2.ebuild b/dev-java/commons-math/commons-math-3.6.1-r2.ebuild
new file mode 100644
index 000000000000..0c33559066fe
--- /dev/null
+++ b/dev-java/commons-math/commons-math-3.6.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc examples source"
+MAVEN_ID="org.apache.commons:commons-math3:3.6.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN}3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="https://commons.apache.org/math/"
+SRC_URI="https://repo1.maven.org/maven2/org/apache/commons/${MY_PN}/${PV}/${MY_P}-sources.jar"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+JAVA_AUTOMATIC_MODULE_NAME="commons.math3"