summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-12-05 10:17:15 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-12-05 11:37:30 +0100
commit50f7a75fbc337ba67fb6cac15c5af4c707b5a188 (patch)
treee083fb275fffedd29789d211bcd2369704db4f72 /dev-java/commons-net/commons-net-3.9.0.ebuild
parentdev-embedded/esptool: add 4.4 (diff)
downloadgentoo-50f7a75fbc337ba67fb6cac15c5af4c707b5a188.tar.gz
gentoo-50f7a75fbc337ba67fb6cac15c5af4c707b5a188.tar.bz2
gentoo-50f7a75fbc337ba67fb6cac15c5af4c707b5a188.zip
dev-java/commons-net: add 3.9.0
Bug: https://bugs.gentoo.org/884201 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/28545 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/commons-net/commons-net-3.9.0.ebuild')
-rw-r--r--dev-java/commons-net/commons-net-3.9.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/commons-net/commons-net-3.9.0.ebuild b/dev-java/commons-net/commons-net-3.9.0.ebuild
new file mode 100644
index 000000000000..9c7298427146
--- /dev/null
+++ b/dev-java/commons-net/commons-net-3.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc examples source"
+MAVEN_ID="commons-net:commons-net:3.9.0"
+# No tests, junit-jupiter and junit-vintage are not packaged.
+# JAVA_TESTING_FRAMEWORKS="junit-vintage junit-jupiter"
+
+inherit java-pkg-2 java-pkg-simple verify-sig
+
+DESCRIPTION="Client-oriented Java library to implement many Internet protocols"
+HOMEPAGE="https://commons.apache.org/proper/commons-net/"
+SRC_URI="mirror://apache/commons/net/source/commons-net-${PV}-src.tar.gz
+ verify-sig? ( https://downloads.apache.org/commons/net/source/commons-net-${PV}-src.tar.gz.asc )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-apache-commons )"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/commons.apache.org.asc"
+
+DOCS=(
+ CONTRIBUTING.md
+ NOTICE.txt
+ README.md
+ RELEASE-NOTES.txt
+)
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_AUTOMATIC_MODULE_NAME="org.apache.commons.net"
+JAVA_ENCODING="iso-8859-1"
+JAVA_RESOURCE_DIRS="src/main/resources"
+JAVA_SRC_DIR="src/main/java"