summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-22 15:22:11 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-22 15:50:12 +0000
commite507992ddbed0445c234ab7c642f0218a74f6101 (patch)
tree3b2584de70f1102570665c8efc554171dfe86fcd /dev-java/commons-primitives/commons-primitives-1.0-r3.ebuild
parentdev-java/snip: Stable for amd64. Retroactively mark stable for the remaining ... (diff)
downloadgentoo-e507992ddbed0445c234ab7c642f0218a74f6101.tar.gz
gentoo-e507992ddbed0445c234ab7c642f0218a74f6101.tar.bz2
gentoo-e507992ddbed0445c234ab7c642f0218a74f6101.zip
dev-java/commons-primitives: EAPI 5 bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/commons-primitives/commons-primitives-1.0-r3.ebuild')
-rw-r--r--dev-java/commons-primitives/commons-primitives-1.0-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-java/commons-primitives/commons-primitives-1.0-r3.ebuild b/dev-java/commons-primitives/commons-primitives-1.0-r3.ebuild
new file mode 100644
index 000000000000..d67c38973b46
--- /dev/null
+++ b/dev-java/commons-primitives/commons-primitives-1.0-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="The Jakarta-Commons Primitives Component"
+HOMEPAGE="http://commons.apache.org/primitives/"
+SRC_URI="https://www.apache.org/dist/commons/primitives/source/${P}-src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ source? ( app-arch/zip )
+ >=virtual/jdk-1.6"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+ rm -rf src/test || die
+}