summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-transaction
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-transaction')
-rw-r--r--dev-java/commons-transaction/Manifest1
-rw-r--r--dev-java/commons-transaction/commons-transaction-1.2.ebuild45
-rw-r--r--dev-java/commons-transaction/metadata.xml10
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-java/commons-transaction/Manifest b/dev-java/commons-transaction/Manifest
new file mode 100644
index 000000000000..c56d85d71a73
--- /dev/null
+++ b/dev-java/commons-transaction/Manifest
@@ -0,0 +1 @@
+DIST commons-transaction-1.2-src.tar.gz 868372 SHA256 9ba7fd4b48f6a5b9ffbc8069ddcf2d9a3dd53bae269809cb55fd1569a832bc8f SHA512 397a3da012ac1220c6f0c8fd7adf744f5e08658a202639b5232496455597b53cba61afdf0f7fbb5e9ebad1d16162270157c892e316993714461f8bfd51791bff WHIRLPOOL 09a6790ef7641a20117abc66eeeb94ea0f048951f790aa2cc380f3be06ae480fb8beca489dcf9db74b2f4a5d5df0b367a57d1669e9888bac278d991586375c17
diff --git a/dev-java/commons-transaction/commons-transaction-1.2.ebuild b/dev-java/commons-transaction/commons-transaction-1.2.ebuild
new file mode 100644
index 000000000000..5b19f143a136
--- /dev/null
+++ b/dev-java/commons-transaction/commons-transaction-1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A library of utility classes commonly used in transactional Java programming"
+SRC_URI="mirror://apache/commons/transaction/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4
+ dev-java/commons-codec:0
+ java-virtuals/transaction-api
+ dev-java/log4j:0
+ dev-java/commons-logging:0
+ dev-java/glassfish-connector-api:0"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ rm -v *.jar lib/*.jar || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="commons-codec,log4j,transaction-api,commons-logging,glassfish-connector-api"
+EANT_DOC_TARGET="javadocs"
+EANT_EXTRA_ARGS="-Djta.present=true -Djca.present=true -Dservlet.present=true"
+
+src_install() {
+ java-pkg_newjar dist/lib/${P}.jar ${PN}.jar
+
+ dodoc NOTICE.txt README.txt RELEASE-NOTES.txt || die
+ dohtml -r xdocs/* || die
+ use doc && java-pkg_dojavadoc build/doc/apidocs
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-transaction/metadata.xml b/dev-java/commons-transaction/metadata.xml
new file mode 100644
index 000000000000..89a65435ed4c
--- /dev/null
+++ b/dev-java/commons-transaction/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ Commons Transaction aims at providing lightweight, standardized, well
+ tested and efficient implementations of utility classes commonly used
+ in transactional Java programming.
+ </longdescription>
+</pkgmetadata>