summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-validator/commons-validator-1.4.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-validator/commons-validator-1.4.0.ebuild')
-rw-r--r--dev-java/commons-validator/commons-validator-1.4.0.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-java/commons-validator/commons-validator-1.4.0.ebuild b/dev-java/commons-validator/commons-validator-1.4.0.ebuild
new file mode 100644
index 000000000000..b33072655c42
--- /dev/null
+++ b/dev-java/commons-validator/commons-validator-1.4.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="examples source test" # doc
+
+inherit java-pkg-2 java-ant-2
+
+MY_P=${P}-src
+
+DESCRIPTION="Commons component to validate user input, or data input"
+HOMEPAGE="http://commons.apache.org/validator/"
+SRC_URI="mirror://apache/commons/validator/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/commons-digester-1.6:0
+ >=dev-java/commons-collections-3.1:0
+ >=dev-java/commons-logging-1.0.4:0
+ dev-java/commons-beanutils:1.7"
+
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/junit:0 )
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ epatch "${FILESDIR}"/validator-1.4.build.xml.patch
+
+ JAVA_ANT_CLASSPATH_TAGS="javac java" java-ant_rewrite-classpath
+
+ echo "commons-digester.jar=$(java-pkg_getjars commons-digester)" >> build.properties
+ echo "commons-beanutils.jar=$(java-pkg_getjars commons-beanutils-1.7)" >> build.properties
+ echo "commons-logging.jar=$(java-pkg_getjar commons-logging commons-logging.jar)" >> build.properties
+ echo "commons-collections.jar=$(java-pkg_getjars commons-collections)" >> build.properties
+}
+
+EANT_JAVA_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="commons-beanutils-1.7,commons-collections"
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},commons-digester,commons-logging,junit"
+
+EANT_BUILD_TARGET="compile"
+EANT_EXTRA_ARGS="-Dskip.download=true"
+
+src_compile() {
+ java-pkg-2_src_compile
+ jar -cf ${PN}.jar -C target/classes/ . || die "Could not create jar."
+
+ if use test ; then
+ eant compile.tests ${EANT_EXTRA_ARGS} -Dgentoo.classpath="$(java-pkg_getjars --build-only --with-dependencies ${EANT_TEST_GENTOO_CLASSPATH})"
+ jar -cf ${PN}-test.jar -C target/tests/ . || die "Could not create test jar."
+ fi
+}
+
+# Missing test suite org.apache.commons.validator.ValidatorTestSuite; therefore, tests can't be ran.
+# See https://issues.apache.org/jira/browse/VALIDATOR-323 for a bug report about this.
+RESTRICT="test"
+
+src_test() {
+ echo "junit.jar=$(java-pkg_getjars junit)" >> build.properties
+ eant test ${EANT_EXTRA_ARGS} -Dgentoo.classpath="$(java-pkg_getjars --build-only --with-dependencies ${EANT_TEST_GENTOO_CLASSPATH}):${PN}.jar:${PN}-test.jar"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ dodoc NOTICE.txt RELEASE-NOTES.txt
+
+ # Docs are no longer generated, as they have commented them out;
+ # probably on purpose, since this is the start of a new branch.
+ # use doc && java-pkg_dojavadoc dist/docs/apidocs
+ use examples && java-pkg_doexamples src/example
+ use source && java-pkg_dosrc src/main/java/*
+}