summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-vfs/commons-vfs-2.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-vfs/commons-vfs-2.0-r1.ebuild')
-rw-r--r--dev-java/commons-vfs/commons-vfs-2.0-r1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-java/commons-vfs/commons-vfs-2.0-r1.ebuild b/dev-java/commons-vfs/commons-vfs-2.0-r1.ebuild
new file mode 100644
index 000000000000..ebef964920ed
--- /dev/null
+++ b/dev-java/commons-vfs/commons-vfs-2.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A single API for accessing various different file systems"
+HOMEPAGE="http://commons.apache.org/vfs/"
+SRC_URI="mirror://apache/commons/vfs/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+CDEPEND="
+ dev-java/ant-core:0
+ dev-java/commons-collections:0
+ dev-java/commons-logging:0
+ dev-java/commons-net:0
+ dev-java/commons-httpclient:3
+ dev-java/jackrabbit-webdav:0
+ dev-java/jsch:0
+ "
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${P}/core"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${P}-incompatibility.patch
+
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ java-ant_rewrite-classpath
+ java-ant_ignore-system-classes
+}
+
+EANT_GENTOO_CLASSPATH="
+ ant-core
+ commons-collections
+ commons-logging
+ commons-net
+ commons-httpclient-3
+ jackrabbit-webdav
+ jsch
+"
+EANT_EXTRA_ARGS="-Dlibdir=${T}"
+
+# The build.xml is generated from maven and can't run the tests properly
+# Use maven test to execute these manually but that means downloading deps from
+# the internet. Also the tests need to login to some ftp servers and samba
+# shares so I doubt they work for everyone.
+#src_test() {
+# ANT_TASKS="ant-junit" eant test
+#}
+
+src_install() {
+ java-pkg_newjar target/*.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java
+}