summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-09-10 22:05:07 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-10 22:47:25 +0200
commit1bd467273a2b3f36a9291b1a3c89107ac024dae0 (patch)
treeb4af0ef8259179836bb3c85a308f0c76fe8e568d /dev-java/cssparser/cssparser-0.9.23.ebuild
parentsys-boot/plymouth: stable 0.9.3-r1 for ppc64, bug #630530 (diff)
downloadgentoo-1bd467273a2b3f36a9291b1a3c89107ac024dae0.tar.gz
gentoo-1bd467273a2b3f36a9291b1a3c89107ac024dae0.tar.bz2
gentoo-1bd467273a2b3f36a9291b1a3c89107ac024dae0.zip
dev-java/cssparser: version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-java/cssparser/cssparser-0.9.23.ebuild')
-rw-r--r--dev-java/cssparser/cssparser-0.9.23.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/cssparser/cssparser-0.9.23.ebuild b/dev-java/cssparser/cssparser-0.9.23.ebuild
new file mode 100644
index 000000000000..4e2aa29ee99f
--- /dev/null
+++ b/dev-java/cssparser/cssparser-0.9.23.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="API for parsing CSS 2 in Java"
+HOMEPAGE="http://cssparser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-sources.jar -> ${P}.jar"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/sac:0"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+JAVA_GENTOO_CLASSPATH="sac"