summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-09-24 20:50:57 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-09-24 20:51:37 +0000
commitc6069658b354f68efceea1a101001d573b694c6b (patch)
treeeb8ac1b2464cb197baf7b93ba38faedbd0b06b55 /dev-java/dict4j/dict4j-1.1.ebuild
parentapp-crypt/pinentry: Restructure dependencies in 0.9.6-r4 (diff)
downloadgentoo-c6069658b354f68efceea1a101001d573b694c6b.tar.gz
gentoo-c6069658b354f68efceea1a101001d573b694c6b.tar.bz2
gentoo-c6069658b354f68efceea1a101001d573b694c6b.zip
dev-java/dict4j: Initial commit. Fixes bug 503758.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/dict4j/dict4j-1.1.ebuild')
-rw-r--r--dev-java/dict4j/dict4j-1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-java/dict4j/dict4j-1.1.ebuild b/dev-java/dict4j/dict4j-1.1.ebuild
new file mode 100644
index 000000000000..0f1319850109
--- /dev/null
+++ b/dev-java/dict4j/dict4j-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Dict protocol implementation in Java"
+HOMEPAGE="http://dict4j.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.jar"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc source"
+
+DEPEND=""
+
+RDEPEND=">=virtual/jre-1.6
+ ${DEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${DEPEND}"
+
+JAVA_SRC_DIR="net"
+JAVA_ENCODING="ISO-8859-1"