summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/hamcrest-integration/hamcrest-integration-1.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/hamcrest-integration/hamcrest-integration-1.3.ebuild')
-rw-r--r--dev-java/hamcrest-integration/hamcrest-integration-1.3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/hamcrest-integration/hamcrest-integration-1.3.ebuild b/dev-java/hamcrest-integration/hamcrest-integration-1.3.ebuild
new file mode 100644
index 000000000000..f9ae6e5c589f
--- /dev/null
+++ b/dev-java/hamcrest-integration/hamcrest-integration-1.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN=${PN/-integration}
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Integration library of hamcrest"
+HOMEPAGE="http://code.google.com/p/${MY_PN}/"
+SRC_URI="http://${MY_PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/hamcrest-core:${SLOT}
+ dev-java/qdox:1.6
+ dev-java/easymock:3.2
+ dev-java/jmock:1.0"
+
+DEPEND=">=virtual/jdk-1.5
+ userland_GNU? ( sys-apps/findutils )
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+JAVA_ANT_CLASSPATH_TAGS="${JAVA_ANT_CLASSPATH_TAGS} java java-to-jar"
+
+EANT_GENTOO_CLASSPATH="hamcrest-core:${SLOT},qdox:1.6,easymock:3.2,jmock:1.0"
+EANT_BUILD_TARGET="integration"
+EANT_EXTRA_ARGS="-Dversion=${PV}"
+EANT_GENTOO_CLASSPATH_EXTRA="build/${P}.jar"
+
+java_prepare() {
+ # remove core+generator target as they are already built.
+ epatch "${FILESDIR}/${PV}-remove-targets.patch"
+
+ find -iname "*.jar" -exec rm -v {} + || die "Unable to clean bundled JAR files"
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+
+ use source && java-pkg_dosrc ${PN}/src/main/java/org
+}