summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-05-10 10:42:46 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-10 16:46:07 +0200
commit0be9ae93c59cdce8cfb6a6d195965a7b3ab48471 (patch)
tree2d61f2a3c224e1de25403d0b756251cbbfd9be83 /dev-java/jakarta-xml-soap-api/jakarta-xml-soap-api-1.4.2.ebuild
parentRevert "sys-apps/keyutils: sparc stable wrt bug #789837" (diff)
downloadgentoo-0be9ae93c59cdce8cfb6a6d195965a7b3ab48471.tar.gz
gentoo-0be9ae93c59cdce8cfb6a6d195965a7b3ab48471.tar.bz2
gentoo-0be9ae93c59cdce8cfb6a6d195965a7b3ab48471.zip
dev-java/jakarta-xml-soap-api: virtual/jdk-1.8:*" -> -11:*
Bug: https://bugs.gentoo.org/843557 Closes: https://github.com/gentoo/gentoo/pull/25415 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/jakarta-xml-soap-api/jakarta-xml-soap-api-1.4.2.ebuild')
-rw-r--r--dev-java/jakarta-xml-soap-api/jakarta-xml-soap-api-1.4.2.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-java/jakarta-xml-soap-api/jakarta-xml-soap-api-1.4.2.ebuild b/dev-java/jakarta-xml-soap-api/jakarta-xml-soap-api-1.4.2.ebuild
deleted file mode 100644
index cd78fb76c776..000000000000
--- a/dev-java/jakarta-xml-soap-api/jakarta-xml-soap-api-1.4.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# This version provides module java.xml.soap and package javax.xml.soap
-MAVEN_ID="jakarta.xml.soap:jakarta.xml.soap-api:1.4.2"
-
-JAVA_PKG_IUSE="doc source test"
-JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="SOAP with Attachments API for Java (SAAJ) API (Eclipse Project for JAX-WS)"
-HOMEPAGE="https://projects.eclipse.org/projects/ee4j.jaxws"
-SRC_URI="https://github.com/eclipse-ee4j/saaj-api/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-# EDL-1.0 equivalent to BSD
-# - 'SPDX-License-Identifier: BSD-3-Clause' in source files' headers
-# - https://www.eclipse.org/org/documents/edl-v10.php
-LICENSE="BSD"
-# Since version 2.0.0, the namespace has changed to jakarta.xml.soap
-SLOT="1"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-CP_DEPEND="
- dev-java/jakarta-activation-api:1
-"
-
-DEPEND="
- >=virtual/jdk-1.8:*
- ${CP_DEPEND}
-"
-
-RDEPEND="
- >=virtual/jre-1.8:*
- ${CP_DEPEND}
-"
-
-S="${WORKDIR}/saaj-api-${PV}"
-
-JAVA_SRC_DIR="api/src/main/java"
-
-JAVA_TEST_GENTOO_CLASSPATH="junit-4"
-JAVA_TEST_SRC_DIR="api/src/test/java"
-JAVA_TEST_RESOURCE_DIRS=( "api/src/test/resources" )
-
-DOCS=( CONTRIBUTING.md NOTICE.md README.md )
-
-src_test() {
- if ver_test "$(java-config -g PROVIDES_VERSION)" -lt 9; then
- # https://github.com/javaee/javax.xml.soap/blob/1.4.0/pom.xml#L134-L143
- JAVA_TEST_EXTRA_ARGS=( -Xbootclasspath/p:target/classes )
- else
- # '-Xbootclasspath/p' removed since JDK 9; '-Xbootclasspath/a' remains
- # https://openjdk.java.net/jeps/261
- JAVA_TEST_EXTRA_ARGS=( -Xbootclasspath/a:target/classes )
- fi
- java-pkg-simple_src_test
-}
-
-src_install() {
- java-pkg-simple_src_install
- einstalldocs # https://bugs.gentoo.org/789582
-}