summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2020-07-20 15:05:01 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-23 14:56:04 +0200
commitfe2ae2d8c00ebcdc28bcacfac7e5cc92f5c8889b (patch)
treedc21be7be726daf6a3fb5ea84301fae9cd158666 /dev-java/jansi-native/jansi-native-1.8.ebuild
parentdev-python/pycuda: Do not depend on setuptools (diff)
downloadgentoo-fe2ae2d8c00ebcdc28bcacfac7e5cc92f5c8889b.tar.gz
gentoo-fe2ae2d8c00ebcdc28bcacfac7e5cc92f5c8889b.tar.bz2
gentoo-fe2ae2d8c00ebcdc28bcacfac7e5cc92f5c8889b.zip
dev-java/jansi-native: verbump to 1.8
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16752 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/jansi-native/jansi-native-1.8.ebuild')
-rw-r--r--dev-java/jansi-native/jansi-native-1.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/jansi-native/jansi-native-1.8.ebuild b/dev-java/jansi-native/jansi-native-1.8.ebuild
new file mode 100644
index 000000000000..c4c23041e597
--- /dev/null
+++ b/dev-java/jansi-native/jansi-native-1.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit vcs-snapshot java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Native JNI component for dev-java/jansi"
+HOMEPAGE="http://jansi.fusesource.org/"
+SRC_URI="https://github.com/fusesource/${PN}/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+CDEPEND="dev-java/hawtjni-runtime:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_GENTOO_CLASSPATH="hawtjni-runtime"
+
+src_prepare() {
+ # Easier to use java-pkg-simple.
+ rm -v pom.xml || die
+
+ default
+}
+
+src_install() {
+ java-pkg-simple_src_install
+
+ dodoc {changelog,readme}.md
+}