summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-10-17 11:35:18 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-10-18 11:53:24 +0100
commitbc7215cd9e99c931f1d7989ad1f47f8e2616c999 (patch)
treebc5e937edd2c8fee6d1078bc3226febb8f10d750 /dev-java/java-sdk-docs/java-sdk-docs-1.8.0.192.ebuild
parentnet-libs/gsoap: Fixed parallel make issue. (diff)
downloadgentoo-bc7215cd9e99c931f1d7989ad1f47f8e2616c999.tar.gz
gentoo-bc7215cd9e99c931f1d7989ad1f47f8e2616c999.tar.bz2
gentoo-bc7215cd9e99c931f1d7989ad1f47f8e2616c999.zip
dev-java/java-sdk-docs: Version bump to 1.8.0.192
Straight to stable as the old version has gone. Signed-off-by: James Le Cuirot <chewi@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-java/java-sdk-docs/java-sdk-docs-1.8.0.192.ebuild')
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.8.0.192.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.192.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.192.ebuild
new file mode 100644
index 000000000000..290ac84e7cb9
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.192.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
+
+[[ "$(ver_cut 4)" == 0 ]] \
+ || MY_PV_EXT="u$(ver_cut 4)"
+
+MY_PV="$(ver_cut 2)${MY_PV_EXT}"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/8/docs/"
+SRC_URI="jdk-${MY_PV}-docs-all.zip"
+LICENSE="oracle-java-documentation-8"
+SLOT="1.8"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from"
+ einfo "${DOWNLOAD_URL}"
+ einfo "by agreeing to the license and place it in your distfiles directory."
+ einfo ""
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report it in bug #67266 (link below)."
+ einfo ""
+ einfo "If emerge fails because of a checksum error, it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_prepare() {
+ default
+
+ # Don't need both .Z and .bz2 archives.
+ find -name "*.Z" -delete || die
+}
+
+src_install() {
+ insinto /usr/share/doc/${PN}-${SLOT}/html
+ doins -r index.html */
+}