summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jdbc-mssqlserver/jdbc-mssqlserver-4.0.2206.100.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jdbc-mssqlserver/jdbc-mssqlserver-4.0.2206.100.ebuild')
-rw-r--r--dev-java/jdbc-mssqlserver/jdbc-mssqlserver-4.0.2206.100.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/jdbc-mssqlserver/jdbc-mssqlserver-4.0.2206.100.ebuild b/dev-java/jdbc-mssqlserver/jdbc-mssqlserver-4.0.2206.100.ebuild
new file mode 100644
index 000000000000..30b2dd9f6090
--- /dev/null
+++ b/dev-java/jdbc-mssqlserver/jdbc-mssqlserver-4.0.2206.100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit java-pkg-2 versionator
+
+MY_PN="sqljdbc"
+MY_P="${MY_PN}-${PV}"
+MY_ID="02AAE597-3865-456C-AE7F-613F99F850A8"
+
+DESCRIPTION="JDBC driver for Microsoft SQL Server"
+HOMEPAGE="http://msdn.microsoft.com/en-US/data/aa937724.aspx"
+SRC_URI="http://download.microsoft.com/download/${MY_ID:0:1}/${MY_ID:1:1}/${MY_ID:2:1}/${MY_ID}/${MY_PN}_${PV}_enu.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="MSjdbcEULA40"
+SLOT="4.0"
+
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=">=virtual/jre-1.6"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}/${MY_PN}_$(get_version_component_range 1-2)/enu"
+
+src_install() {
+ dodoc release.txt || die
+ if use doc; then
+ dohtml -r help/*
+ fi
+ java-pkg_dojar *.jar
+}