summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jdbc-mysql/jdbc-mysql-5.1.23.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jdbc-mysql/jdbc-mysql-5.1.23.ebuild')
-rw-r--r--dev-java/jdbc-mysql/jdbc-mysql-5.1.23.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/dev-java/jdbc-mysql/jdbc-mysql-5.1.23.ebuild b/dev-java/jdbc-mysql/jdbc-mysql-5.1.23.ebuild
new file mode 100644
index 000000000000..f3b85571a355
--- /dev/null
+++ b/dev-java/jdbc-mysql/jdbc-mysql-5.1.23.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+JAVA_PKG_WANT_BOOTCLASSPATH="1.5"
+WANT_ANT_TASKS="ant-contrib"
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_PN="mysql-connector-java"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MySQL JDBC driver"
+HOMEPAGE="http://www.mysql.com/products/connector/j/"
+SRC_URI="mirror://mysql/Downloads/Connector-J/${MY_P}.tar.gz"
+
+LICENSE="GPL-2-with-MySQL-FLOSS-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+IUSE="c3p0 log4j"
+
+COMMON_DEP="
+ dev-java/slf4j-api:0
+ log4j? ( dev-java/log4j )
+ c3p0? ( dev-java/c3p0 )"
+
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ epatch "${FILESDIR}/5.0.5-remove-jboss-dependency-from-tests.patch"
+
+ # http://bugs.mysql.com/bug.php?id=28286
+ epatch "${FILESDIR}/5.0.5-dist-target-depends.patch"
+
+ # Use java6 for everything except jdbc3 - #283848
+ epatch "${FILESDIR}/5.1.14-java6.patch"
+
+ find . -name '*.jar' -print -delete || die
+
+ # use test && mkdir src/lib-nodist # needed, or ant will fail
+
+ cd src/lib
+ java-pkg_jar-from slf4j-api
+ use log4j && java-pkg_jar-from log4j
+ use c3p0 && java-pkg_jar-from c3p0
+}
+
+JAVA_ANT_IGNORE_SYSTEM_CLASSES="true"
+EANT_BUILD_TARGET="dist"
+
+src_compile() {
+ # Cannot use rewrite-bootclasspath because of the jdbc4 part.
+ java-pkg-2_src_compile \
+ -Dgentoo.bootclasspath="$(java-pkg_get-bootclasspath 1.5)"
+}
+
+# Tests need a mysql DB to exist.
+RESTRICT="test"
+
+src_test() {
+ cd src/lib
+ java-pkg_jar-from junit
+
+ cd "${S}"
+ ANT_TASKS="ant-junit" eant test -Dcom.mysql.jdbc.noCleanBetweenCompiles=true
+}
+
+src_install() {
+ # Skip bytecode check because we want two versions there
+ JAVA_PKG_STRICT= java-pkg_newjar build/${MY_P}-SNAPSHOT/${MY_P}-SNAPSHOT-bin.jar ${PN}.jar
+
+ dodoc README CHANGES
+ dohtml docs/*.html
+
+ use source && java-pkg_dosrc src/com src/org
+}