summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jgoodies-common
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jgoodies-common')
-rw-r--r--dev-java/jgoodies-common/Manifest2
-rw-r--r--dev-java/jgoodies-common/jgoodies-common-1.2.1.ebuild46
-rw-r--r--dev-java/jgoodies-common/jgoodies-common-1.8.0.ebuild38
-rw-r--r--dev-java/jgoodies-common/metadata.xml6
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-java/jgoodies-common/Manifest b/dev-java/jgoodies-common/Manifest
new file mode 100644
index 000000000000..92618081e07e
--- /dev/null
+++ b/dev-java/jgoodies-common/Manifest
@@ -0,0 +1,2 @@
+DIST jgoodies-common-1_2_1.zip 271803 SHA256 0fe2ede31e70a633c2a157b99594701e4206c4207f7a3f6e97b15121cac32dfb SHA512 c31c00e9a79eacec92a20cecd0b3e8c3a5739e14f46bdc1b348c801925777d5433077c5f0c81e5526f95aa2d993449115c517945a3381185663494c6e4577d92 WHIRLPOOL 3edbddb83405867437ca2ef97466b4e9a3509c2b117ca6666425679cbb6ef7d7e44bdbd615728efdbc687e81e6602e7057b57f26af1b55b3a94114d598ae2362
+DIST jgoodies-common-1_8_0.zip 575972 SHA256 602873af50ca8251623cb7f2fcfb9d4289844834670dba10c143e70380cad685 SHA512 c00ffb6498b40b214bccad3ee8f0f3a9231bb8e67243be5ea15956694466485ac75aeed09f340aea323c6989190c10015b7a72b82d5a251bb5ea12ddaedb6b25 WHIRLPOOL 61dc47e3c00842999572b49c61d6fa6383f44dbe658647202f6599ea00b76e301903af2386bce4134a777fed00f5f307f6e16d1a31fd821700fed4d2216d18a8
diff --git a/dev-java/jgoodies-common/jgoodies-common-1.2.1.ebuild b/dev-java/jgoodies-common/jgoodies-common-1.2.1.ebuild
new file mode 100644
index 000000000000..380240e588a6
--- /dev/null
+++ b/dev-java/jgoodies-common/jgoodies-common-1.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_PN="common"
+MY_PV=${PV//./_}
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="JGoodies Common Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+java_prepare() {
+ # Remove the packaged jars
+ find . -name "*.jar" -delete || die "rm failed"
+}
+
+src_compile() {
+ # it does not like unset ${build.compiler.executable}
+ # feel free to fix if you want jikes back
+ java-pkg_filter-compiler jikes
+ # not setting the bootcp breaks ecj, javac apparently ignores nonsense
+ eant -Dbuild.boot.classpath="$(java-config -g BOOTCLASSPATH)" jar
+}
+
+src_install() {
+ java-pkg_dojar build/${PN}.jar
+
+ dodoc RELEASE-NOTES.txt README.html || die
+
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/core/com
+}
diff --git a/dev-java/jgoodies-common/jgoodies-common-1.8.0.ebuild b/dev-java/jgoodies-common/jgoodies-common-1.8.0.ebuild
new file mode 100644
index 000000000000..d1077902aae9
--- /dev/null
+++ b/dev-java/jgoodies-common/jgoodies-common-1.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="common"
+MY_PV=${PV//./_}
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="JGoodies Common Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="1.8"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"/${P}
+
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+ mkdir src || die
+ unzip ${P}-sources.jar -d src || die
+ rm "${S}"/pom.xml "${S}"/*.jar || die
+}
diff --git a/dev-java/jgoodies-common/metadata.xml b/dev-java/jgoodies-common/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/dev-java/jgoodies-common/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+