summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-30 19:43:41 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-30 19:43:58 +0000
commit64294da8792f870172388c749a3adcdb5ff56738 (patch)
treedfb7d835b7766eae3b77804cb723e047649ca635 /dev-java/jibx/jibx-1.2.6.ebuild
parentdev-perl/Wx: Disable one misbehaving test (diff)
downloadgentoo-64294da8792f870172388c749a3adcdb5ff56738.tar.gz
gentoo-64294da8792f870172388c749a3adcdb5ff56738.tar.bz2
gentoo-64294da8792f870172388c749a3adcdb5ff56738.zip
dev-java/jibx: Version bump.
Gentoo-Bug: https://bugs.gentoo.org/269764 Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/jibx/jibx-1.2.6.ebuild')
-rw-r--r--dev-java/jibx/jibx-1.2.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/jibx/jibx-1.2.6.ebuild b/dev-java/jibx/jibx-1.2.6.ebuild
new file mode 100644
index 000000000000..97a03657b5c2
--- /dev/null
+++ b/dev-java/jibx/jibx-1.2.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Bind XML to Java code"
+HOMEPAGE="http://jibx.sourceforge.net/"
+SRC_URI="
+ https://repo1.maven.org/maven2/org/${PN}/${PN}-extras/${PV}/${PN}-extras-${PV}-sources.jar
+ https://repo1.maven.org/maven2/org/${PN}/${PN}-bind/${PV}/${PN}-bind-${PV}-sources.jar
+ https://repo1.maven.org/maven2/org/${PN}/${PN}-run/${PV}/${PN}-run-${PV}-sources.jar
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+CDEPEND="
+ dev-java/bcel:0
+ dev-java/xpp3:0
+ dev-java/jdom:0
+ dev-java/dom4j:1
+ dev-java/log4j:0
+ dev-java/joda-time:0
+ dev-java/ant-core:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"
+
+JAVA_GENTOO_CLASSPATH="
+ joda-time
+ ant-core
+ dom4j-1
+ log4j
+ jdom
+ bcel
+ xpp3
+"