summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jmdns
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jmdns')
-rw-r--r--dev-java/jmdns/Manifest3
-rw-r--r--dev-java/jmdns/jmdns-1.0.ebuild47
-rw-r--r--dev-java/jmdns/jmdns-3.1.4.ebuild29
-rw-r--r--dev-java/jmdns/jmdns-3.4.1.ebuild30
-rw-r--r--dev-java/jmdns/metadata.xml13
5 files changed, 122 insertions, 0 deletions
diff --git a/dev-java/jmdns/Manifest b/dev-java/jmdns/Manifest
new file mode 100644
index 000000000000..e486518335c0
--- /dev/null
+++ b/dev-java/jmdns/Manifest
@@ -0,0 +1,3 @@
+DIST jmdns-1.0-Final.tar.gz 157799 SHA256 eed717e220f13e0063f09cd9b0bb9fe43dbe9d8ac68b7fa184bae5ce2864295b SHA512 62fc4e0a8ce42acb8f414299d6d59a313a3a201fb634777a77be78bff679eae4c2068959e035d82d6b6159cb1a42abfdce02509d9b511f36d8aea6eb3a19c6b4 WHIRLPOOL 060b316324596157a056abda9cdf5114b5801702ea948e8c5c44755cb32d15e919647fadfba2826766337e7525a0dbaf56c85335ce443455c047e1361190533d
+DIST jmdns-3.1.4.tgz 275127 SHA256 3824642f040d358745952e8e5e8686d45a4f18a9ed4605e5b72eae8e082386ab SHA512 4c644b02f814fb8c6ea81d74ee18697eecfa2e57de73bebe2b3b1ac89c7f5b45143c55c343426bce2ac38bd0ac82aa316b5af6a704bd9732ebac6224c3ed8e44 WHIRLPOOL ba4e27f9d3f42656df816a02b41d5a81bfa866727c3a6c513607bc3d35152e66a082f809ccaada69d82dc9cf5a9d2e1af55333070161762fa14a6ea6f35bf856
+DIST jmdns-3.4.1.tgz 665503 SHA256 aefc28fcb0a8d8d563abfe0b764fa91a2737aa8b19f8a8f859a96a50fe663ebe SHA512 06e01dc7ef9eabd1ba75be016d688294043a6eec53de40d20026587f2c3d82bd0b025efd9b662bbe28450940d277da0fbc30ef69293ca3e81426212d8e85d7fb WHIRLPOOL 1df820435d9d1ad72daaff2d2467eb0d5080b8e74bbb9b18da7333feabdf48b25b39cdd29d453535b00ea3f2a20231282e49a9bf845075815bef6eb498bdd9f8
diff --git a/dev-java/jmdns/jmdns-1.0.ebuild b/dev-java/jmdns/jmdns-1.0.ebuild
new file mode 100644
index 000000000000..48803902de0c
--- /dev/null
+++ b/dev-java/jmdns/jmdns-1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2
+
+DESCRIPTION="JmDNS is an implementation of multi-cast DNS in Java"
+SRC_URI="mirror://sourceforge/${PN}/${P}-Final.tar.gz"
+HOMEPAGE="http://jmdns.sourceforge.net"
+IUSE=""
+DEPEND=">=virtual/jdk-1.3.1"
+RDEPEND=">=virtual/jre-1.3.1"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm lib/*.jar
+}
+
+src_compile() {
+ echo "Compiling JmDNS..."
+ ejavac "${S}"/src/javax/jmdns/* || die
+ echo "Compiling tools..."
+ ejavac -classpath "${S}/src" "${S}"/src/com/strangeberry/jmdns/tools/* || die
+ echo "Making jars..."
+ echo "Main-class: com.strangeberry.jmdns.tools.Main" > jmdns-tools-manifest
+ jar cmf jmdns-tools-manifest jmdns.jar -C "${S}/src" com -C "${S}/src" javax || die
+}
+
+src_install() {
+ java-pkg_dojar jmdns*.jar
+ java-pkg_dolauncher
+ dodoc README.txt CHANGELOG.txt
+
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc src/{com,javax}
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/
+ doins -r src/samples
+ fi
+}
diff --git a/dev-java/jmdns/jmdns-3.1.4.ebuild b/dev-java/jmdns/jmdns-3.1.4.ebuild
new file mode 100644
index 000000000000..20ddd5ec7ee4
--- /dev/null
+++ b/dev-java/jmdns/jmdns-3.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JmDNS is an implementation of multi-cast DNS in Java"
+SRC_URI="mirror://sourceforge/${PN}/${PF}.tgz"
+HOMEPAGE="http://jmdns.sourceforge.net"
+
+LICENSE="Apache-2.0"
+SLOT="3.1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${P}"
+JAVA_SRC_DIR="src"
+
+src_prepare() {
+ rm "${S}"/build.xml
+ rm "${S}"/lib/*.jar || die
+}
diff --git a/dev-java/jmdns/jmdns-3.4.1.ebuild b/dev-java/jmdns/jmdns-3.4.1.ebuild
new file mode 100644
index 000000000000..5b50bcc61b28
--- /dev/null
+++ b/dev-java/jmdns/jmdns-3.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JmDNS is an implementation of multi-cast DNS in Java"
+SRC_URI="mirror://sourceforge/${PN}/${PF}.tgz"
+HOMEPAGE="http://jmdns.sourceforge.net"
+
+LICENSE="Apache-2.0"
+SLOT="3.4"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}"
+JAVA_SRC_DIR="src"
+
+src_prepare() {
+ rm "${S}"/build.xml || die
+ find -name "*.jar" -delete || die
+ find "${JAVA_SRC_DIR}" -name "*Test.java" -delete || die
+}
diff --git a/dev-java/jmdns/metadata.xml b/dev-java/jmdns/metadata.xml
new file mode 100644
index 000000000000..d35fc3014bda
--- /dev/null
+++ b/dev-java/jmdns/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ JmDNS is an implementation of multi-cast DNS in Java.
+ It supports service discovery and service registration.
+ It is fully interoperable with Apple's Rendezvous.
+ </longdescription>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jmdns</remote-id>
+ </upstream>
+</pkgmetadata>