summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jmock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jmock')
-rw-r--r--dev-java/jmock/Manifest3
-rw-r--r--dev-java/jmock/files/1.1.0-build.xml.patch21
-rw-r--r--dev-java/jmock/files/1.1.0-junit-3.8.2.patch12
-rw-r--r--dev-java/jmock/files/2.5.1-invokeAll-invokeAny.patch30
-rw-r--r--dev-java/jmock/jmock-1.2.0.ebuild40
-rw-r--r--dev-java/jmock/jmock-2.5.1.ebuild45
-rw-r--r--dev-java/jmock/jmock-2.6.1.ebuild44
-rw-r--r--dev-java/jmock/metadata.xml5
8 files changed, 200 insertions, 0 deletions
diff --git a/dev-java/jmock/Manifest b/dev-java/jmock/Manifest
new file mode 100644
index 000000000000..a2bec409f5e7
--- /dev/null
+++ b/dev-java/jmock/Manifest
@@ -0,0 +1,3 @@
+DIST jmock-1.2.0-jars.zip 153318 SHA256 c98e8dd0e5ebb590578baf4eb095b0c69084cd448269cac6c7dd52075ced5b36 SHA512 7b854c462e04642444f8994875d496655986a094b113f888c8dd5f07149c41c4e97e23f8f0cf75822b4e8281ffb90054ac44024cacd3f6e55ef0659e463f0cc5 WHIRLPOOL b2563df867f481706a9a7ebf4b5535321bcb295c42233575fb657908c232cda8416d3e1a5c78b67d41a311efdb0760ad5984278ae9cc02ea81868184767cc88a
+DIST jmock-2.5.1-jars.zip 758019 SHA256 e5f8d704d732a4e0d2a7788d966e6c8cfc722707bf278b6c0618f9d46eae6e7a SHA512 97032dd3f7f2b8e4e310e04722af0f444a60b0908ca45111b0ad1578f92ddac411c9d66f6eb696f45134c8baced86c10194b5ebbd8974090a585e95583dd2a9c WHIRLPOOL 1e50a9da3f8a16f4f706f2631f2a9aee89a89067c1a365284c116e6bdd7a4e5c4ac9a828317e13e49d097ad59bb7cd4f7d49cf99ed47055a17b2faa418300f94
+DIST jmock-2.6.1-jars.zip 1249841 SHA256 e49a0f7628c6368e46de1c48dfd8aed084f03661d87cf3a78025fdec367021fb SHA512 7cd1d2e89dceb31c68ad3f702ad937b5de6ec77cc37e94be7aa53db2fc61d11aa40ec5aab225a3eeeba5064ad8384f10413ac05a9df97102c8e63f4209ea149e WHIRLPOOL e67be30e6718b998a34a52cdaa59ba7afc19969b5fe08529ea056867c0b8b3fad2628eb04b8b0b778bd215d29fe4aa962b0021afbb64835eac845f76c4b5987d
diff --git a/dev-java/jmock/files/1.1.0-build.xml.patch b/dev-java/jmock/files/1.1.0-build.xml.patch
new file mode 100644
index 000000000000..22b47eefa23a
--- /dev/null
+++ b/dev-java/jmock/files/1.1.0-build.xml.patch
@@ -0,0 +1,21 @@
+diff -ur jmock-1.1.0.old/build.xml jmock-1.1.0/build.xml
+--- jmock-1.1.0.old/build.xml 2006-12-23 00:06:19.000000000 +0200
++++ jmock-1.1.0/build.xml 2006-12-23 00:06:49.000000000 +0200
+@@ -116,7 +116,7 @@
+ </junit>
+ </target>
+
+- <target name="core.jar" depends="core.test.unit">
++ <target name="core.jar" depends="core.compile">
+ <mkdir dir="${build.dist.bin.dir}"/>
+ <jar basedir="${core.build.dir}" destfile="${core.jar}" excludes="test/**" index="true"/>
+ </target>
+@@ -181,7 +181,7 @@
+ </junit>
+ </target>
+
+- <target name="cglib.jar" depends="cglib.test.unit">
++ <target name="cglib.jar" depends="cglib.compile">
+ <mkdir dir="${build.dist.bin.dir}"/>
+ <jar basedir="${cglib.build.dir}" destfile="${cglib.jar}" excludes="test/**" index="true"/>
+ </target>
diff --git a/dev-java/jmock/files/1.1.0-junit-3.8.2.patch b/dev-java/jmock/files/1.1.0-junit-3.8.2.patch
new file mode 100644
index 000000000000..411e2423a0a7
--- /dev/null
+++ b/dev-java/jmock/files/1.1.0-junit-3.8.2.patch
@@ -0,0 +1,12 @@
+diff -ur jmock-1.1.0.old/core/src/org/jmock/expectation/AssertMo.java jmock-1.1.0/core/src/org/jmock/expectation/AssertMo.java
+--- jmock-1.1.0.old/core/src/org/jmock/expectation/AssertMo.java 2006-12-22 23:56:07.000000000 +0200
++++ jmock-1.1.0/core/src/org/jmock/expectation/AssertMo.java 2006-12-22 23:56:17.000000000 +0200
+@@ -73,7 +73,7 @@
+ assertTrue("Should not have verified", threwException);
+ }
+
+- static protected void failNotEquals( String message,
++ static public void failNotEquals( String message,
+ Object expected,
+ Object actual ) {
+ String formatted = "";
diff --git a/dev-java/jmock/files/2.5.1-invokeAll-invokeAny.patch b/dev-java/jmock/files/2.5.1-invokeAll-invokeAny.patch
new file mode 100644
index 000000000000..7acfc8598f03
--- /dev/null
+++ b/dev-java/jmock/files/2.5.1-invokeAll-invokeAny.patch
@@ -0,0 +1,30 @@
+diff --git a/jmock-2.5.1/src/org/jmock/lib/concurrent/DeterministicScheduler.java b/jmock-2.5.1/src/org/jmock/lib/concurrent/DeterministicScheduler.java
+index 6dbc020..0dce41c 100644
+--- a/jmock-2.5.1/src/org/jmock/lib/concurrent/DeterministicScheduler.java
++++ b/jmock-2.5.1/src/org/jmock/lib/concurrent/DeterministicScheduler.java
+@@ -110,21 +110,21 @@ public class DeterministicScheduler implements ScheduledExecutorService {
+ throw blockingOperationsNotSupported();
+ }
+
+- public <T> List<Future<T>> invokeAll(Collection<Callable<T>> tasks) throws InterruptedException {
++ public <T> List<Future<T>> invokeAll(Collection<? extends Callable<T>> tasks) throws InterruptedException {
+ throw blockingOperationsNotSupported();
+ }
+
+- public <T> List<Future<T>> invokeAll(Collection<Callable<T>> tasks, long timeout, TimeUnit unit) throws InterruptedException {
++ public <T> List<Future<T>> invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit) throws InterruptedException {
+ throw blockingOperationsNotSupported();
+ }
+
+- public <T> T invokeAny(Collection<Callable<T>> tasks)
++ public <T> T invokeAny(Collection<? extends Callable<T>> tasks)
+ throws InterruptedException, ExecutionException
+ {
+ throw blockingOperationsNotSupported();
+ }
+
+- public <T> T invokeAny(Collection<Callable<T>> tasks, long timeout, TimeUnit unit)
++ public <T> T invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
+ throws InterruptedException, ExecutionException, TimeoutException
+ {
+ throw blockingOperationsNotSupported();
diff --git a/dev-java/jmock/jmock-1.2.0.ebuild b/dev-java/jmock/jmock-1.2.0.ebuild
new file mode 100644
index 000000000000..f525933753cf
--- /dev/null
+++ b/dev-java/jmock/jmock-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Library for testing Java code using mock objects"
+SRC_URI="http://${PN}.codehaus.org/dist/${P}-jars.zip"
+HOMEPAGE="http://jmock.codehaus.org"
+
+LICENSE="BSD"
+SLOT="1.0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+CDEPEND="dev-java/junit:0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="junit"
+
+src_unpack() {
+ unpack ${A}
+ unzip ${PN}-core-${PV}.jar -d src || die
+}
+
+java_prepare() {
+ rm *.jar || die
+ find -name "*.class" -delete || die
+ epatch "${FILESDIR}/1.1.0-junit-3.8.2.patch"
+}
diff --git a/dev-java/jmock/jmock-2.5.1.ebuild b/dev-java/jmock/jmock-2.5.1.ebuild
new file mode 100644
index 000000000000..fc9f6e59fb30
--- /dev/null
+++ b/dev-java/jmock/jmock-2.5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Library for testing Java code using mock objects"
+SRC_URI="http://${PN}.codehaus.org/dist/${P}-jars.zip"
+HOMEPAGE="http://jmock.codehaus.org"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-java/hamcrest-core:1.3
+ dev-java/hamcrest-library:1.3"
+
+RDEPEND="virtual/jre:1.6
+ ${CDEPEND}"
+
+DEPEND="virtual/jdk:1.6
+ ${CDEPEND}
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="hamcrest-core-1.3,hamcrest-library-1.3"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ unzip ${P}.jar -d src || die
+ rm *.jar || die
+}
+
+src_prepare() {
+ find -name "*.class" -delete || die
+
+ epatch "${FILESDIR}/${PV}-invokeAll-invokeAny.patch"
+}
diff --git a/dev-java/jmock/jmock-2.6.1.ebuild b/dev-java/jmock/jmock-2.6.1.ebuild
new file mode 100644
index 000000000000..56b0a25fb94a
--- /dev/null
+++ b/dev-java/jmock/jmock-2.6.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Library for testing Java code using mock objects"
+SRC_URI="http://www.jmock.org/downloads/${P}-jars.zip"
+HOMEPAGE="http://www.jmock.org"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CDEPEND="dev-java/hamcrest-core:1.3
+ dev-java/hamcrest-library:1.3
+ dev-java/junit:4"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="hamcrest-core-1.3,hamcrest-library-1.3,junit-4"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ unzip ${P}.jar -d src || die
+ rm *.jar || die
+}
+
+src_prepare() {
+ find -name "*.class" -delete || die
+}
diff --git a/dev-java/jmock/metadata.xml b/dev-java/jmock/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/jmock/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>