summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-08-28 10:46:32 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-08-28 10:51:16 +0000
commiteee278a2b0820637106b9ce7d81fe427124283c2 (patch)
tree3a17413c157bbae2e8301744830650b26be498fd /dev-java/jmock
parentdev-java/appframework: Drop old. (diff)
downloadgentoo-eee278a2b0820637106b9ce7d81fe427124283c2.tar.gz
gentoo-eee278a2b0820637106b9ce7d81fe427124283c2.tar.bz2
gentoo-eee278a2b0820637106b9ce7d81fe427124283c2.zip
dev-java/jmock: Change the compilation logic. Fixes bug 558908.
After yesterday's fix i.e. HOMEPAGE and SRC_URI pointing to new URLs, I wrongly assumed the package structure was the same, which, unfortunately, isn't the case. Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/jmock')
-rw-r--r--dev-java/jmock/files/1.1.0-build.xml.patch21
-rw-r--r--dev-java/jmock/files/1.1.0-junit-3.8.2.patch12
-rw-r--r--dev-java/jmock/files/jmock-1.2.0-AbstractMo.patch27
-rw-r--r--dev-java/jmock/jmock-1.2.0-r1.ebuild48
4 files changed, 75 insertions, 33 deletions
diff --git a/dev-java/jmock/files/1.1.0-build.xml.patch b/dev-java/jmock/files/1.1.0-build.xml.patch
deleted file mode 100644
index 22b47eefa23a..000000000000
--- a/dev-java/jmock/files/1.1.0-build.xml.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ur jmock-1.1.0.old/build.xml jmock-1.1.0/build.xml
---- jmock-1.1.0.old/build.xml 2006-12-23 00:06:19.000000000 +0200
-+++ jmock-1.1.0/build.xml 2006-12-23 00:06:49.000000000 +0200
-@@ -116,7 +116,7 @@
- </junit>
- </target>
-
-- <target name="core.jar" depends="core.test.unit">
-+ <target name="core.jar" depends="core.compile">
- <mkdir dir="${build.dist.bin.dir}"/>
- <jar basedir="${core.build.dir}" destfile="${core.jar}" excludes="test/**" index="true"/>
- </target>
-@@ -181,7 +181,7 @@
- </junit>
- </target>
-
-- <target name="cglib.jar" depends="cglib.test.unit">
-+ <target name="cglib.jar" depends="cglib.compile">
- <mkdir dir="${build.dist.bin.dir}"/>
- <jar basedir="${cglib.build.dir}" destfile="${cglib.jar}" excludes="test/**" index="true"/>
- </target>
diff --git a/dev-java/jmock/files/1.1.0-junit-3.8.2.patch b/dev-java/jmock/files/1.1.0-junit-3.8.2.patch
deleted file mode 100644
index 411e2423a0a7..000000000000
--- a/dev-java/jmock/files/1.1.0-junit-3.8.2.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur jmock-1.1.0.old/core/src/org/jmock/expectation/AssertMo.java jmock-1.1.0/core/src/org/jmock/expectation/AssertMo.java
---- jmock-1.1.0.old/core/src/org/jmock/expectation/AssertMo.java 2006-12-22 23:56:07.000000000 +0200
-+++ jmock-1.1.0/core/src/org/jmock/expectation/AssertMo.java 2006-12-22 23:56:17.000000000 +0200
-@@ -73,7 +73,7 @@
- assertTrue("Should not have verified", threwException);
- }
-
-- static protected void failNotEquals( String message,
-+ static public void failNotEquals( String message,
- Object expected,
- Object actual ) {
- String formatted = "";
diff --git a/dev-java/jmock/files/jmock-1.2.0-AbstractMo.patch b/dev-java/jmock/files/jmock-1.2.0-AbstractMo.patch
new file mode 100644
index 000000000000..1e3a939d26d3
--- /dev/null
+++ b/dev-java/jmock/files/jmock-1.2.0-AbstractMo.patch
@@ -0,0 +1,27 @@
+--- src/org/jmock/expectation/AssertMo.java.orig 2015-08-28 10:15:13.490000000 +0000
++++ src/org/jmock/expectation/AssertMo.java 2015-08-28 10:15:22.206000000 +0000
+@@ -73,15 +73,15 @@
+ assertTrue("Should not have verified", threwException);
+ }
+
+- static protected void failNotEquals( String message,
+- Object expected,
+- Object actual ) {
+- String formatted = "";
+- if (message != null) {
+- formatted = message + " ";
+- }
+- fail(formatted + "\nExpected:<" + expected + ">\nReceived:<" + actual + ">");
+- }
++// static protected void failNotEquals( String message,
++// Object expected,
++// Object actual ) {
++// String formatted = "";
++// if (message != null) {
++// formatted = message + " ";
++// }
++// fail(formatted + "\nExpected:<" + expected + ">\nReceived:<" + actual + ">");
++// }
+
+ public static void notImplemented( String mockName ) {
+ throw new NotImplementedException("Not Implemented in " + mockName);
diff --git a/dev-java/jmock/jmock-1.2.0-r1.ebuild b/dev-java/jmock/jmock-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..fc191a93d86d
--- /dev/null
+++ b/dev-java/jmock/jmock-1.2.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Library for testing Java code using mock objects"
+SRC_URI="http://www.${PN}.org/downloads/${P}-jars.zip"
+HOMEPAGE="http://www.jmock.org/"
+
+LICENSE="BSD"
+SLOT="1.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+CDEPEND="dev-java/junit:0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src"
+JAVA_GENTOO_CLASSPATH="junit"
+
+src_unpack() {
+ default
+ unpack ${A}
+ unzip "${S}"/"${PN}-core-${PV}.jar" -d src || die
+ mv src "${S}" || die
+}
+
+java_prepare() {
+ find -name "*.class" -delete || die
+ rm *.jar || die
+
+ # This patch isn't changing the behaviour if jmock per se.
+ # Only the formatting is altered.
+ epatch "${FILESDIR}"/"${P}-AbstractMo.patch"
+}