summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValérian Rousset <tharvik@users.noreply.github.com>2023-04-14 20:55:57 +0200
committerSam James <sam@gentoo.org>2023-05-20 10:21:45 +0100
commit5aedc2bd66fc9317738102ed0379bc8f75237d79 (patch)
treeebb2fa63dae15fc5d5b580e44322350f15053489 /dev-java/json-smart/json-smart-1.3.3.ebuild
parentdev-java/jbcrypt: new package, add 0.4 (diff)
downloadgentoo-5aedc2bd66fc9317738102ed0379bc8f75237d79.tar.gz
gentoo-5aedc2bd66fc9317738102ed0379bc8f75237d79.tar.bz2
gentoo-5aedc2bd66fc9317738102ed0379bc8f75237d79.zip
dev-java/json-smart: new package, add 1.3.3
Signed-off-by: Valérian Rousset <tharvik@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java/json-smart/json-smart-1.3.3.ebuild')
-rw-r--r--dev-java/json-smart/json-smart-1.3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/json-smart/json-smart-1.3.3.ebuild b/dev-java/json-smart/json-smart-1.3.3.ebuild
new file mode 100644
index 000000000000..2249a996229c
--- /dev/null
+++ b/dev-java/json-smart/json-smart-1.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="net.minidev:json-smart:1.3.3"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="old JSON parser"
+HOMEPAGE="https://urielch.github.io"
+SRC_URI="https://github.com/netplex/json-smart-v1/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/${PN}-v1-${PV}/json-smart"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"