summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/maven-bin/maven-bin-3.2.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/maven-bin/maven-bin-3.2.5.ebuild')
-rw-r--r--dev-java/maven-bin/maven-bin-3.2.5.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/dev-java/maven-bin/maven-bin-3.2.5.ebuild b/dev-java/maven-bin/maven-bin-3.2.5.ebuild
new file mode 100644
index 000000000000..601fe9bf10e4
--- /dev/null
+++ b/dev-java/maven-bin/maven-bin-3.2.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit java-pkg-2
+
+MY_PN=apache-${PN%%-bin}
+MY_PV=${PV/_alpha/-alpha-}
+MY_P="${MY_PN}-${MY_PV}"
+MY_MV="${PV%%.*}"
+
+DESCRIPTION="Project Management and Comprehension Tool for Java"
+SRC_URI="mirror://apache/maven/maven-${MY_MV}/${PV}/binaries/${MY_P}-bin.tar.gz"
+HOMEPAGE="http://maven.apache.org/"
+
+LICENSE="Apache-2.0"
+SLOT="3.2"
+KEYWORDS="~amd64 ~x86"
+
+# TODO: Needs further resolution:
+#
+# - https://bugs.gentoo.org/show_bug.cgi?id=472850
+# - https://bugs.gentoo.org/show_bug.cgi?id=477436
+#
+DEPEND="|| ( app-eselect/eselect-java app-eselect/eselect-maven )
+|| ( dev-java/commons-logging:0 dev-java/log4j:0 dev-java/avalon-logkit:2.0 )
+dev-java/aopalliance:1
+dev-java/avalon-framework:4.1
+dev-java/commons-cli:1
+dev-java/commons-io:1
+dev-java/javax-inject:0
+dev-java/jsoup:0
+dev-java/jsr250:0
+dev-java/juel:0
+dev-java/osgi-core-api:0
+java-virtuals/interceptor-api:0
+java-virtuals/servlet-api:2.4"
+
+RDEPEND=">=virtual/jdk-1.6
+>=virtual/jre-1.6
+${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+MAVEN=${PN}-${SLOT}
+MAVEN_SHARE="/usr/share/${MAVEN}"
+
+java_prepare() {
+ rm -v bin/*.bat lib/{aopalliance,commons-cli,javax.inject,jsr250}-*.jar || die
+
+ chmod 644 boot/*.jar lib/*.jar conf/settings.xml || die
+
+ # Symlink jars.
+ cd lib || die
+ java-pkg_jar-from aopalliance-1,avalon-framework-4.1,commons-cli-1,commons-io-1,interceptor-api,javax-inject,jsoup,jsr250,juel,osgi-core-api,servlet-api-2.4
+ has_version dev-java/commons-logging:0 && java-pkg_jar-from commons-logging
+ has_version dev-java/avalon-logkit:2.0 && java-pkg_jar-from avalon-logkit-2.0
+ has_version dev-java/log4j:0 && java-pkg_jar-from log4j
+}
+
+# TODO: We should use jars from packages, instead of what is bundled.
+src_install() {
+ dodir "${MAVEN_SHARE}"
+
+ cp -Rp bin boot conf lib "${ED}/${MAVEN_SHARE}" || die "failed to copy"
+
+ java-pkg_regjar "${ED}/${MAVEN_SHARE}"/boot/*.jar
+ java-pkg_regjar "${ED}/${MAVEN_SHARE}"/lib/*.jar
+
+ dodoc NOTICE README.txt
+
+ dodir /usr/bin
+ dosym "${MAVEN_SHARE}/bin/mvn" /usr/bin/mvn-${SLOT}
+
+ # See bug #342901.
+ echo "CONFIG_PROTECT=\"${MAVEN_SHARE}/conf\"" > "${T}/25${MAVEN}" || die
+ doenvd "${T}/25${MAVEN}"
+}
+
+pkg_postinst() {
+ eselect maven update mvn-${SLOT}
+}
+
+pkg_postrm() {
+ eselect maven update
+}