summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-04-04 22:43:28 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-04-07 22:45:33 +0100
commitc7e010feac692c8eed36742bb1df1e17273ad590 (patch)
tree57673c9d7b2be17e9fd211814e3b06b5a71cf2b8 /dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild
parentwww-client/chromium: dev channel bump (51.0.2700.0) (diff)
downloadgentoo-c7e010feac692c8eed36742bb1df1e17273ad590.tar.gz
gentoo-c7e010feac692c8eed36742bb1df1e17273ad590.tar.bz2
gentoo-c7e010feac692c8eed36742bb1df1e17273ad590.zip
dev-java/maven-hawtjni-plugin: New package, resources only
We currently don't use Maven in ebuilds and we haven't found the need to build the many plugins. This one has useful resource files for building netty-tcnative and potentially other native libraries. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild')
-rw-r--r--dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild b/dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild
new file mode 100644
index 000000000000..f614eaff7fc5
--- /dev/null
+++ b/dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2
+
+MY_P="hawtjni-project-${PV}"
+
+DESCRIPTION="Maven plugin for the HawtJNI code generator (resources only)"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/hawtjni-${MY_P}/${PN}"
+
+src_compile() {
+ touch ${PN}.jar || die # jar won't create on update.
+ java-pkg_addres ${PN}.jar src/main/resources
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+}