summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValérian Rousset <tharvik@users.noreply.github.com>2023-03-10 00:32:51 +0100
committerSam James <sam@gentoo.org>2023-05-20 10:21:45 +0100
commit42a14f1a9dc14485f8af4628e91cced357db7a86 (patch)
treebecf189dbf7f5ea59b09fcc6870f89625c491be7 /dev-java/minidns-core/minidns-core-1.0.4.ebuild
parentdev-java/jsonrpc2-server: new package, add 1.11.1 (diff)
downloadgentoo-42a14f1a9dc14485f8af4628e91cced357db7a86.tar.gz
gentoo-42a14f1a9dc14485f8af4628e91cced357db7a86.tar.bz2
gentoo-42a14f1a9dc14485f8af4628e91cced357db7a86.zip
dev-java/minidns-core: new package, add 1.0.4
Signed-off-by: Valérian Rousset <tharvik@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java/minidns-core/minidns-core-1.0.4.ebuild')
-rw-r--r--dev-java/minidns-core/minidns-core-1.0.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/minidns-core/minidns-core-1.0.4.ebuild b/dev-java/minidns-core/minidns-core-1.0.4.ebuild
new file mode 100644
index 000000000000..53eb84f6bb3f
--- /dev/null
+++ b/dev-java/minidns-core/minidns-core-1.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.minidns:minidns-core:1.0.4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="DNS library for Java and Android systems"
+HOMEPAGE="https://github.com/minidns/minidns"
+SRC_URI="https://github.com/MiniDNS/minidns/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/minidns-${PV}/${PN}"
+
+JAVA_SRC_DIR="src/main/java"
+# needs junit:5
+#JAVA_TESTING_FRAMEWORKS="junit-5"
+#JAVA_TEST_SRC_DIR="src/test/java"
+#JAVA_TEST_RESOURCE_DIRS="src/test/resources"