summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/odfdom
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/odfdom')
-rw-r--r--dev-java/odfdom/Manifest1
-rw-r--r--dev-java/odfdom/files/build-0.8.6.xml270
-rw-r--r--dev-java/odfdom/metadata.xml6
-rw-r--r--dev-java/odfdom/odfdom-0.8.6-r1.ebuild65
4 files changed, 342 insertions, 0 deletions
diff --git a/dev-java/odfdom/Manifest b/dev-java/odfdom/Manifest
new file mode 100644
index 000000000000..3c1dd7a01671
--- /dev/null
+++ b/dev-java/odfdom/Manifest
@@ -0,0 +1 @@
+DIST odfdom-0.8.6-sources.zip 33171275 SHA256 fcb5ecefd07081073b50c023e2b49090400e8d152d5f06ea93c87f5db012bfd2 SHA512 7b71d55da01d604d89c5e0c7b9efcfd67e926db6807c885cb34cb9bd2e1fb1dc4a38d8e75967e08913b7ab1dcd85e7165d561fd3585a3d0c63df35a1a12c44e0 WHIRLPOOL b14ec321387b96b0df96d78a204e999548e671b023750efbdbbaae633babbee54a924dd9a20bb6c1e1888aa9c397cd9d0ea8946c8109767ab0918ef0e085ff7d
diff --git a/dev-java/odfdom/files/build-0.8.6.xml b/dev-java/odfdom/files/build-0.8.6.xml
new file mode 100644
index 000000000000..a2750f73a117
--- /dev/null
+++ b/dev-java/odfdom/files/build-0.8.6.xml
@@ -0,0 +1,270 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 1/17/11 1:59 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- Also contains some hand made modifications -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="odfdom-java-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="odfdom"/>
+ <property name="maven.build.version" value="0.8.6"/>
+ <property name="maven.build.odfversion" value="1.2"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="lib"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <fileset dir="lib">
+ <include name="xercesImpl-2.9.1.jar"/>
+ <include name="xml-apis-1.3.04.jar"/>
+ </fileset>
+ </path>
+ <path id="build.test.classpath">
+ <fileset dir="lib">
+ <include name="xercesImpl-2.9.1.jar"/>
+ <include name="xml-apis-1.3.04.jar"/>
+ <include name="junit-4.5.jar"/>
+ <include name="hamcrest-core.jar"/>
+ </fileset>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ memoryMaximumSize="512m"
+ memoryInitialSize="1024m"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ memoryMaximumSize="512m"
+ memoryInitialSize="1024m"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <sysproperty key="odfdom.version" value="${maven.build.version}"/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="true"
+ windowtitle="ODFDOM API v0.8.6 - http://odftoolkit"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"
+ maxmemory="1024m">
+ <doctitle>&lt;![CDATA[ODFDOM]]&gt;</doctitle>
+ <link href="http://java.sun.com/javase/6/docs/api/"/>
+ <link href="http://xerces.apache.org/xerces-j/apiDocs/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="true"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class"
+ value="org.odftoolkit.odfdom.JarManifest"/>
+ <attribute name="version" value="${maven.build.version}"/>
+ <section name="ODFDOM">
+ <attribute name="ODFDOM-Built-By" value="Gentoo"/>
+ <attribute name="ODFDOM-Built-Date" value="${TODAY}"/>
+ <attribute name="ODFDOM-Name" value="odfdom"/>
+ <attribute name="ODFDOM-Supported-Odf-Version" value="${maven.build.odfversion}"/>
+ <attribute name="ODFDOM-Version" value="${maven.build.version}"/>
+ <attribute name="ODFDOM-Website" value="http://odftoolkit.org"/>
+ </section>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+</project>
diff --git a/dev-java/odfdom/metadata.xml b/dev-java/odfdom/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/dev-java/odfdom/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+
diff --git a/dev-java/odfdom/odfdom-0.8.6-r1.ebuild b/dev-java/odfdom/odfdom-0.8.6-r1.ebuild
new file mode 100644
index 000000000000..201aea7f09e0
--- /dev/null
+++ b/dev-java/odfdom/odfdom-0.8.6-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The ODFDOM reference implementation, written in Java"
+HOMEPAGE="http://odftoolkit.org/projects/odfdom"
+SRC_URI="http://odftoolkit.org/projects/odfdom/downloads/download/current-version%252F${P}-sources.zip -> ${P}-sources.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+CDEPEND="dev-java/xerces:2
+ dev-java/xml-commons-external:1.4"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}
+ test? (
+ dev-java/ant-junit4:0
+ dev-java/hamcrest-core:0
+ dev-java/junit:4
+ )"
+
+S="${WORKDIR}/${P}-sources"
+
+EANT_GENTOO_CLASSPATH="xerces-2,xml-commons-external-1.4"
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+java_prepare() {
+ cp "${FILESDIR}/build-${PV}.xml" build.xml || die
+
+ mkdir lib || die
+
+ # These tests fail.
+ rm -v src/test/java/org/odftoolkit/odfdom/doc/DocumentCreationTest.java \
+ src/test/java/org/odftoolkit/odfdom/doc/PresentationTest.java \
+ src/test/java/org/odftoolkit/odfdom/doc/ImageTest.java \
+ src/test/java/org/odftoolkit/odfdom/incubator/meta/MetaDocumentStatisticTest.java \
+ src/test/java/org/odftoolkit/odfdom/incubator/meta/OfficeMetaTest.java
+}
+
+EANT_BUILD_TARGET="package"
+EANT_JAVADOC_TARGET="javadoc"
+EANT_EXTRA_ARGS="-Dmaven.test.skip=true"
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},hamcrest-core,junit-4"
+
+src_test() {
+ EANT_EXTRA_ARGS="" \
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar target/odfdom.jar
+
+ dodoc README.txt LICENSE.txt || die
+ use doc && java-pkg_dojavadoc target/site/apidocs
+}