summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-14 03:37:34 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-14 03:39:38 -0800
commit15e159c630e112ed3a2e29eacc62e80cdbe5aed0 (patch)
treef9e9a26ae91acf8d784961a9c3d20b624cb82570 /dev-java/openjdk-bin
parentdev-java/openjdk: remove gentoo-vm warning (diff)
downloadgentoo-15e159c630e112ed3a2e29eacc62e80cdbe5aed0.tar.gz
gentoo-15e159c630e112ed3a2e29eacc62e80cdbe5aed0.tar.bz2
gentoo-15e159c630e112ed3a2e29eacc62e80cdbe5aed0.zip
dev-java/openjdk-bin: remove gentoo-vm warning
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-java/openjdk-bin')
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-11.0.13_p8-r1.ebuild14
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-11.0.13_p8.ebuild14
2 files changed, 2 insertions, 26 deletions
diff --git a/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8-r1.ebuild b/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8-r1.ebuild
index 95bcdeba00a6..dabdb239f42e 100644
--- a/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8-r1.ebuild
+++ b/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -121,16 +121,4 @@ src_install() {
pkg_postinst() {
java-vm-2_pkg_postinst
-
- if use gentoo-vm ; then
- ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
- ewarn "recognised by the system. This will almost certainly break"
- ewarn "many java ebuilds as they are not ready for openjdk-11"
- else
- ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
- ewarn "will not be recognised by the system. For example, simply calling"
- ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
- ewarn "fully supports Java 11. This JDK must therefore be invoked using its"
- ewarn "absolute location under ${EPREFIX}/opt/${P}."
- fi
}
diff --git a/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8.ebuild b/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8.ebuild
index 1fd28021ae50..12b3337375bf 100644
--- a/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8.ebuild
+++ b/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -121,16 +121,4 @@ src_install() {
pkg_postinst() {
java-vm-2_pkg_postinst
-
- if use gentoo-vm ; then
- ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
- ewarn "recognised by the system. This will almost certainly break"
- ewarn "many java ebuilds as they are not ready for openjdk-11"
- else
- ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
- ewarn "will not be recognised by the system. For example, simply calling"
- ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
- ewarn "fully supports Java 11. This JDK must therefore be invoked using its"
- ewarn "absolute location under ${EPREFIX}/opt/${P}."
- fi
}