summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-10 00:24:59 -0800
committerJames Le Cuirot <chewi@gentoo.org>2018-11-10 15:21:48 +0000
commit3d6c0e6950ddecc3330039fc5a254dc0a75201ac (patch)
tree16e5da9c8b4e93defaa69e555acc7bf5124cf7e4 /dev-java/openjdk-bin
parentdev-util/uftrace: 0.9.1 (diff)
downloadgentoo-3d6c0e6950ddecc3330039fc5a254dc0a75201ac.tar.gz
gentoo-3d6c0e6950ddecc3330039fc5a254dc0a75201ac.tar.bz2
gentoo-3d6c0e6950ddecc3330039fc5a254dc0a75201ac.zip
dev-java/openjdk-bin: version bump to 11.0.1+13
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org> Signed-off-by: James Le Cuirot <chewi@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/10385
Diffstat (limited to 'dev-java/openjdk-bin')
-rw-r--r--dev-java/openjdk-bin/Manifest3
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-11.0.1_p13.ebuild102
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-java/openjdk-bin/Manifest b/dev-java/openjdk-bin/Manifest
index 56f6f6be6619..bf94ddca9297 100644
--- a/dev-java/openjdk-bin/Manifest
+++ b/dev-java/openjdk-bin/Manifest
@@ -1,3 +1,6 @@
DIST OpenJDK11-jdk_aarch64_linux_hotspot_11_28.tar.gz 193328951 BLAKE2B f7586ed6b5e5562f6b1b4ed155abadbe31cb85459c982b0011e75d85046261c0a78dcaab343fb5c5c7a382c3fd1ac52caefc8194262e35c3601b9aae5a9b94e3 SHA512 b2e5bd25fd62425e25a9a60cd2ca4b080748a352c04c29f206ab121245226c61fa5a8573d342d8bf88efd83a9a7890fd85cf90d700dae28f632878a60d79ea75
DIST OpenJDK11-jdk_ppc64le_linux_hotspot_11_28.tar.gz 176285783 BLAKE2B a64f86a4f69302efe0eb2645d39c44ce89bcf58c765c12c109735fb2ede5959b0659d4b9f85cf8e79102fc6f00443b99a78fc5745086b1b5e16bd41958db1ed7 SHA512 84eb35634a985647d4fc90c6c4a1855c1c059e5fde8cf3ef7665fa754a7549cb3905a1c35710c6c936426efd6e0bc1ac773fbef11550dbadbff622fd2c201d74
DIST OpenJDK11-jdk_x64_linux_hotspot_11_28.tar.gz 195689094 BLAKE2B 4d65b7993fddd113964103a1066faa6e7e83ab7807f6403c1f5bc5a72ca82dc51287d4911e264ba5754b7c1184aa1f1d1c94d19ae242ab02bf238f6c359c0de3 SHA512 f7a427bc33b2e8a2f68c7955b23d14f2eacf7b526f2990b29e55bdb1ae96d3e14f3d7c169c76ba4b18fd8195cef81d7199a37a81ce73d6b21a72f07388e70793
+DIST OpenJDK11U-jdk_aarch64_linux_hotspot_11.0.1_13.tar.gz 193388219 BLAKE2B 21ff9bcd5288a17ff7f660fb9b1bbb6c38589fea72850729227a985dce1966c6d0b0d6c64ad6885c17612d215e58a50cec5f70205877bb26c70924b15f92886b SHA512 200ebd5882e2ebd315a2d0fdd800d70b52d468022ae565756ccd56e1fdd2464b459753cfad6c5f46a61cdda8a003cdfe031c2a6a12e047bbe7ee2133dd048546
+DIST OpenJDK11U-jdk_ppc64le_linux_hotspot_11.0.1_13.tar.gz 179520284 BLAKE2B 32acf913aa1b176ca98af0c6111e7f14bba22b84547e24dac279205bb0c81fc3845239e9e34c897c18452ebbb4c71b8185fc4d7d3a2856f3cc767ed4c268d61c SHA512 3bf9fa8eb4cdad03dbbb648b6ab1d8ed5ed34584abe2bec254626952aeba2fc5d492075ba0308ab8e28824959df5f11bb46ec1638c2588b352dd58a5097c030a
+DIST OpenJDK11U-jdk_x64_linux_hotspot_11.0.1_13.tar.gz 195710782 BLAKE2B a374afea8de4333488294dcb200e235f7cc42309a56e693a9b5434dc74d0189b57c26adc93ef22454a4ed05f44b90afa8fdfc016feb022c1eaeb706044581f24 SHA512 b5e55cd32daa3b30fb84b8f4fed0ef70e4f8e3e153974c0c9fa0fcdf22cade99613da93f2289798b625adde24d9a1c4c4808a139e9f2feb2543b05f273f3bdd8
diff --git a/dev-java/openjdk-bin/openjdk-bin-11.0.1_p13.ebuild b/dev-java/openjdk-bin/openjdk-bin-11.0.1_p13.ebuild
new file mode 100644
index 000000000000..c633ab47d5ca
--- /dev/null
+++ b/dev-java/openjdk-bin/openjdk-bin-11.0.1_p13.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-vm-2
+
+abi_uri() {
+ echo "${2-$1}? (
+ https://github.com/AdoptOpenJDK/openjdk${SLOT}-binaries/releases/download/jdk-${MY_PV}/OpenJDK${SLOT}U-jdk_${1}_linux_hotspot_${MY_PV//+/_}.tar.gz
+ )"
+}
+
+MY_PV=${PV/_p/+}
+SLOT=${MY_PV%%[.+]*}
+
+SRC_URI="
+ $(abi_uri x64 amd64)
+ $(abi_uri aarch64 arm64)
+ $(abi_uri ppc64le ppc64)
+"
+
+DESCRIPTION="Prebuilt Java JDK binaries provided by AdoptOpenJDK"
+HOMEPAGE="https://adoptopenjdk.net"
+LICENSE="GPL-2-with-classpath-exception"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE="alsa cups doc examples +gentoo-vm headless-awt nsplugin selinux source +webstart"
+RESTRICT="preserve-libs splitdebug"
+QA_PREBUILT="*"
+
+RDEPEND="
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ >=sys-libs/glibc-2.2.5:*
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ doc? ( dev-java/java-sdk-docs:${SLOT} )
+ selinux? ( sec-policy/selinux-java )
+ !headless-awt? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ )"
+
+PDEPEND="webstart? ( >=dev-java/icedtea-web-1.6.1:0 )
+ nsplugin? ( >=dev-java/icedtea-web-1.6.1:0[nsplugin] )"
+
+S="${WORKDIR}/jdk-${MY_PV}"
+
+src_install() {
+ local dest="/opt/${P}"
+ local ddest="${ED}${dest#/}"
+
+ # Not sure why they bundle this as it's commonly available and they
+ # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+ # also has an explicit dependency while Oracle seemingly dlopens it.
+ rm -vf lib/libfreetype.so || die
+
+ # Oracle and IcedTea have libjsoundalsa.so depending on
+ # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+ if ! use alsa ; then
+ rm -v lib/libjsound.* || die
+ fi
+
+ if ! use examples ; then
+ rm -vr demo/ || die
+ fi
+
+ if use headless-awt ; then
+ rm -v lib/lib*{[jx]awt,splashscreen}* || die
+ fi
+
+ if ! use source ; then
+ rm -v lib/src.zip || die
+ fi
+
+ dodir "${dest}"
+ cp -pPR * "${ddest}" || die
+
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ java-vm_set-pax-markings "${ddest}"
+ java-vm_revdep-mask
+ java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}
+
+pkg_postinst() {
+ java-vm-2_pkg_postinst
+
+ if use gentoo-vm ; then
+ ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
+ ewarn "recognised by the system. This will almost certainly break things."
+ else
+ ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
+ ewarn "will not be recognised by the system. For example, simply calling"
+ ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
+ ewarn "fully supports Java 11. This JDK must therefore be invoked using its"
+ ewarn "absolute location under ${EPREFIX}/opt/${P}."
+ fi
+}