summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/plexus-classworlds
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/plexus-classworlds')
-rw-r--r--dev-java/plexus-classworlds/Manifest1
-rw-r--r--dev-java/plexus-classworlds/files/2.2.3-build.xml126
-rw-r--r--dev-java/plexus-classworlds/metadata.xml6
-rw-r--r--dev-java/plexus-classworlds/plexus-classworlds-2.2.3.ebuild42
4 files changed, 175 insertions, 0 deletions
diff --git a/dev-java/plexus-classworlds/Manifest b/dev-java/plexus-classworlds/Manifest
new file mode 100644
index 000000000000..6c52690ee9b3
--- /dev/null
+++ b/dev-java/plexus-classworlds/Manifest
@@ -0,0 +1 @@
+DIST plexus-classworlds-2.2.3.tar.bz2 41744 SHA256 fda8ce2db126e3d21f09103818810795924c7c023132b1a6c59179927242013a SHA512 d5f3d3dac4df569b91ddea9265b14a2459b0ecd4ac3e4547cbac341f50d18238071a7a560d9771a9f8724c59225ea7fa8645ed72c5a00a684519a46a024c3c61 WHIRLPOOL ccd9b9e8f94d39635338169a258b4abb5fff798f32da7166b3d4123ff3aa3ad5ed986618bd6c122b456736cdd207df79a965e258330a2820142208b9e54c490f
diff --git a/dev-java/plexus-classworlds/files/2.2.3-build.xml b/dev-java/plexus-classworlds/files/2.2.3-build.xml
new file mode 100644
index 000000000000..ed1e6fe4fb8f
--- /dev/null
+++ b/dev-java/plexus-classworlds/files/2.2.3-build.xml
@@ -0,0 +1,126 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<project name="plexus-classworlds-from-maven" default="package" basedir=".">
+ <property file="${user.home}/.m2/maven.properties" />
+ <property file="maven-build.properties" />
+
+ <property name="maven.build.finalName" value="plexus-classworlds-2.2.3" />
+ <property name="maven.build.dir" value="target" />
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes" />
+ <property name="maven.build.srcDir.0" value="src/main/java" />
+ <property name="maven.build.resourceDir.0" value="src/main/resources" />
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes" />
+ <property name="maven.build.testDir.0" value="src/test/java" />
+ <property name="maven.build.testResourceDir.0" value="src/test/resources" />
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports" />
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site" />
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository" />
+ <property name="maven.settings.offline" value="false" />
+ <property name="maven.settings.interactiveMode" value="true" />
+
+ <path id="build.classpath" />
+ <path id="build.test.classpath" />
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}" />
+ </target>
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}" />
+ <javac destdir="${maven.build.outputDir}" excludes="org/codehaus/plexus/classworlds/event/*" encoding="UTF-8" nowarn="false" debug="true" optimize="false" deprecation="true" target="1.4" verbose="false" fork="false" source="1.4">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}" />
+ </src>
+ <classpath refid="build.classpath" />
+ </javac>
+ </target>
+
+ <target name="compile-tests" depends="compile" description="Compile the test code" unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}" />
+ <javac destdir="${maven.build.testOutputDir}" excludes="org/codehaus/plexus/classworlds/event/*" encoding="UTF-8" nowarn="false" debug="true" optimize="false" deprecation="true" target="1.4" verbose="false" fork="false" source="1.4">
+ <src>
+ <pathelement location="${maven.build.testDir.0}" />
+ </src>
+ <classpath>
+ <path refid="build.test.classpath" />
+ <pathelement location="${maven.build.outputDir}" />
+ </classpath>
+ </javac>
+ </target>
+
+ <target name="test" depends="compile-tests, junit-missing" unless="junit.skipped" description="Run the test cases">
+ <mkdir dir="${maven.test.reports}" />
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="." />
+ <formatter type="xml" />
+ <formatter type="plain" usefile="false" />
+ <classpath>
+ <path refid="build.test.classpath" />
+ <pathelement location="${maven.build.outputDir}" />
+ <pathelement location="${maven.build.testOutputDir}" />
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java" />
+ <include name="**/*Test.java" />
+ <include name="**/*TestCase.java" />
+ <exclude name="**/*Abstract*Test.java" />
+ <exclude name="**/*Abstract*TestCase.java" />
+ <exclude name="**/*TestUtil.java" />
+ <exclude name="**/*ConfiguratorTest.java" />
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java" />
+ <exclude name="**/*Abstract*Test.java" />
+ <exclude name="**/*Abstract*TestCase.java" />
+ <exclude name="**/*TestUtil.java" />
+ <exclude name="**/*ConfiguratorTest.java" />
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" />
+ </target>
+
+ <target name="test-junit-status" depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}" />
+ <isfalse value="${maven.test.skip}" />
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}" />
+ <istrue value="${maven.test.skip}" />
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing" depends="test-junit-status" if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}" packagenames="*" destdir="${maven.reporting.outputDirectory}/apidocs" access="protected" old="false" verbose="false" version="true" use="true" author="true" splitindex="false" nodeprecated="false" nodeprecatedlist="false" notree="false" noindex="false" nohelp="false" nonavbar="false" serialwarn="false" charset="ISO-8859-1" linksource="false" breakiterator="false" />
+ </target>
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar" compress="true" index="false" basedir="${maven.build.outputDir}" excludes="**/package.html" />
+ </target>
+
+ <target name="jar" depends="package" description="Builds the jar for the application" />
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true" />
+ </condition>
+ </target>
+</project>
diff --git a/dev-java/plexus-classworlds/metadata.xml b/dev-java/plexus-classworlds/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/dev-java/plexus-classworlds/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+
diff --git a/dev-java/plexus-classworlds/plexus-classworlds-2.2.3.ebuild b/dev-java/plexus-classworlds/plexus-classworlds-2.2.3.ebuild
new file mode 100644
index 000000000000..1e2693d512de
--- /dev/null
+++ b/dev-java/plexus-classworlds/plexus-classworlds-2.2.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The class loader framework of the Plexus project"
+HOMEPAGE="http://plexus.codehaus.org/"
+SRC_URI="http://dev.gentoo.org/~ercpe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2"
+
+LICENSE="codehaus-classworlds"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6
+ test? ( dev-java/junit:4 )"
+RDEPEND=">=virtual/jre-1.6"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_TEST_GENTOO_CLASSPATH="junit-4"
+EANT_TEST_ANT_TASKS="ant-junit"
+
+java_prepare() {
+ cp "${FILESDIR}"/${PV}-build.xml "${S}"/build.xml || die
+}
+
+src_install() {
+ java-pkg_newjar "${S}/target/${P}.jar" "${PN}.jar"
+
+ use source && java-pkg_dosrc "${S}"/src/main/java/*
+ use doc && java-pkg_dojavadoc "${S}"/target/site/apidocs
+}
+
+src_test() {
+ java-pkg-2_src_test
+}