summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-01-11 11:29:47 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-01-11 11:30:07 +0100
commit0fc591ecb6046131b65a1996fd6cd8710baeb8fd (patch)
treefb7103387964470af27c576c6cd6c617ec43f3ac /dev-java/protobuf-java
parentdev-java/protobuf-java: add 3.21.9-r2, tests enabled (diff)
downloadgentoo-0fc591ecb6046131b65a1996fd6cd8710baeb8fd.tar.gz
gentoo-0fc591ecb6046131b65a1996fd6cd8710baeb8fd.tar.bz2
gentoo-0fc591ecb6046131b65a1996fd6cd8710baeb8fd.zip
dev-java/protobuf-java: use 'assert' instead of 'die' for shell pipelines
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/protobuf-java')
-rw-r--r--dev-java/protobuf-java/protobuf-java-3.21.12.ebuild3
-rw-r--r--dev-java/protobuf-java/protobuf-java-3.21.9-r2.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-java/protobuf-java/protobuf-java-3.21.12.ebuild b/dev-java/protobuf-java/protobuf-java-3.21.12.ebuild
index da7ae95555d7..7885a6ab21ee 100644
--- a/dev-java/protobuf-java/protobuf-java-3.21.12.ebuild
+++ b/dev-java/protobuf-java/protobuf-java-3.21.12.ebuild
@@ -55,7 +55,8 @@ src_prepare() {
"${S}/core/pom.xml") > "${T}/core_proto" || die "echo to core_proto failed"
# Copy them from ../src/google/protobuf to JAVA_RESOURCE_DIRS
pushd "${JAVA_RESOURCE_DIRS}" || die
- jar cv "@${T}/core_proto" | jar xv || die "Copying protos failed"
+ jar cv "@${T}/core_proto" | jar xv
+ assert"Copying protos failed"
popd || die
# https://github.com/protocolbuffers/protobuf/blob/v21.12/java/core/generate-sources-build.xml
diff --git a/dev-java/protobuf-java/protobuf-java-3.21.9-r2.ebuild b/dev-java/protobuf-java/protobuf-java-3.21.9-r2.ebuild
index 9dc32c355b91..ef157767a703 100644
--- a/dev-java/protobuf-java/protobuf-java-3.21.9-r2.ebuild
+++ b/dev-java/protobuf-java/protobuf-java-3.21.9-r2.ebuild
@@ -52,7 +52,8 @@ src_prepare() {
"${S}/core/pom.xml") > "${T}/core_proto" || die "echo to core_proto failed"
# Copy them from ../src/google/protobuf to JAVA_RESOURCE_DIRS
pushd "${JAVA_RESOURCE_DIRS}" || die
- jar cv "@${T}/core_proto" | jar xv || die "Copying protos failed"
+ jar cv "@${T}/core_proto" | jar xv
+ assert "Copying protos failed"
popd || die
# https://github.com/protocolbuffers/protobuf/blob/v21.9/java/core/generate-sources-build.xml