summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-10-27 12:16:34 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-10-27 22:10:59 +0200
commitfc8ebcedde52077364feb69dbed85a5ce41320fb (patch)
tree6e93bd2338b813318e35a4ff4130e1e79f68c6ce /dev-java/protobuf-java
parentdev-java/qdox: add 2.0.1 (diff)
downloadgentoo-fc8ebcedde52077364feb69dbed85a5ce41320fb.tar.gz
gentoo-fc8ebcedde52077364feb69dbed85a5ce41320fb.tar.bz2
gentoo-fc8ebcedde52077364feb69dbed85a5ce41320fb.zip
dev-java/protobuf-java: drop 3.19.6, 3.20.3, both fail to compile
these versions got erroneously added both fail to compile, same error as bug #878393 both are unlikely to be ever used instead of higher version Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/protobuf-java')
-rw-r--r--dev-java/protobuf-java/Manifest2
-rw-r--r--dev-java/protobuf-java/protobuf-java-3.19.6.ebuild102
-rw-r--r--dev-java/protobuf-java/protobuf-java-3.20.3.ebuild102
3 files changed, 0 insertions, 206 deletions
diff --git a/dev-java/protobuf-java/Manifest b/dev-java/protobuf-java/Manifest
index 30346a892702..070283b7af1a 100644
--- a/dev-java/protobuf-java/Manifest
+++ b/dev-java/protobuf-java/Manifest
@@ -1,4 +1,2 @@
DIST protobuf-3.19.3.tar.gz 5293258 BLAKE2B c05b70ffca97f7166ea6a511a36907eed125edf1ebf17f908718221d9b851be84dfb2b1b39973f2faf35f6ade630e6ba4f9e8b91b8fbc922c5db97079323ee6e SHA512 1c003e7cbc8eae6a038f46e688b401ee202ba47f502561e909df79770f6e8b7daf3dc1ccc727e31bfb5b52cd04cb4fef7d2d2a28d650c13f396872ad4aa076c6
-DIST protobuf-3.19.6.tar.gz 5299501 BLAKE2B 3121f76b95f83c5309ce49ce296b738eff7be9d3a5093c564fbe2339fb5f3729e406f1b44bfcc05feb0d31ab63838bb4f54685017977c73a33b91215a6776072 SHA512 8f92242f2be8e1bbfba41341c87709ad91ad83b8b3e3df88bb430411541d3399295f49291fd52b50e3487b0fce33181cb4d175685fd25aac72adfaee26a612d4
-DIST protobuf-3.20.3.tar.gz 5374320 BLAKE2B fb51f2a0ecf5b83235f5252051f8192ae377bb7a5e030c3f3e9435ccde25919c059830cf476e840fa6c970928a32c0075e213c9d5d4d9e3d3b24732c39a9fbfa SHA512 01d6703bdbe769a1200ee6e4ebcdcb99688ec21f576988c60d82ec36e0822820fb245fcb4ca53293143d53e666d748b5a0c6937bc659fb3cdc4cd9b05ed12a1c
DIST protobuf-3.21.8.tar.gz 5113425 BLAKE2B 35bea4b6dfa8fbad543989e91834dc58045307ade30d9427749bb95fefe2b05fa687d898500af1eba951bb9684d6ec93ded4ef721d5d46278ad09013d9475210 SHA512 a9e3ff6fd4b5f4bf86ac58c9b0a35010e7069def08783c0aecc05cc0d6e38f04a1af6b6ad61191c3d3348c1e5e44062f63ce1377141ebbd10f122101ef089088
diff --git a/dev-java/protobuf-java/protobuf-java-3.19.6.ebuild b/dev-java/protobuf-java/protobuf-java-3.19.6.ebuild
deleted file mode 100644
index 6adff3a717e4..000000000000
--- a/dev-java/protobuf-java/protobuf-java-3.19.6.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 2008-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="com.google.protobuf:${PN}:${PV}"
-# Tests not enabled, depend on com.google.truth which is not packaged
-# https://github.com/protocolbuffers/protobuf/blob/v3.19.6/java/core/pom.xml#L35-L40
-# JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-PARENT_PN="${PN/-java/}"
-PARENT_PV="${PV}"
-PARENT_P="${PARENT_PN}-${PARENT_PV}"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/protocolbuffers/protobuf/archive/v${PARENT_PV}.tar.gz
- -> ${PARENT_P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-fi
-
-DESCRIPTION="Google's Protocol Buffers - Java bindings"
-HOMEPAGE="
- https://developers.google.com/protocol-buffers/
-"
-
-LICENSE="BSD"
-SLOT="0/30"
-
-S="${WORKDIR}/${PARENT_P}/java"
-
-BDEPEND="
- dev-libs/protobuf:${SLOT}
-"
-DEPEND="
- >=virtual/jdk-1.8:*
- test? (
- dev-java/guava:0
- dev-java/mockito:4
- )
-"
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-
-JAVA_AUTOMATIC_MODULE_NAME="com.google.protobuf"
-JAVA_JAR_FILENAME="protobuf.jar"
-JAVA_RESOURCE_DIRS="core/src/main/resources"
-JAVA_SRC_DIR="core/src/main/java"
-
-JAVA_TEST_GENTOO_CLASSPATH="guava,junit-4,mockito-4"
-JAVA_TEST_RESOURCE_DIRS="../src"
-JAVA_TEST_SRC_DIR="core/src/test/java"
-
-# Same than PATCHES but from repository's root directory,
-# please see function `src_prepare` below.
-# Simplier for users IMHO.
-PARENT_PATCHES=(
-)
-
-# Here for patches within "java/" subdirectory.
-PATCHES=(
-)
-
-src_prepare() {
- pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
- [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
- eapply_user
- popd > /dev/null || die
-
- # Remove bundled jars
- java-pkg_clean
-
- java-pkg-2_src_prepare
-
- # There is also compiler/plugin, but not in this list because in a subdirectory
- core_protos=( any api descriptor duration empty field_mask source_context struct timestamp type wrappers )
-
- # Copy resources from ../src/google/protobuf according to
- # https://github.com/protocolbuffers/protobuf/blob/v3.19.6/java/core/pom.xml#L45-L61
- mkdir -p "${JAVA_RESOURCE_DIRS}/google/protobuf/compiler" || die
- cp "../src/google/protobuf/${core_protos[@]}.proto" \
- "${JAVA_RESOURCE_DIRS}/google/protobuf" || die
- cp {../src,"${JAVA_RESOURCE_DIRS}"}/google/protobuf/compiler/plugin.proto || die
-
- # Generate 146 .java files according to
- # https://github.com/protocolbuffers/protobuf/blob/v3.19.6/java/core/generate-sources-build.xml
- for proto in "${core_protos[@]}" compiler/plugin; do
- "${BROOT}/usr/bin/protoc" \
- --java_out="${JAVA_SRC_DIR}" -I../src ../src/google/protobuf/"${proto}".proto || die
- done
-}
diff --git a/dev-java/protobuf-java/protobuf-java-3.20.3.ebuild b/dev-java/protobuf-java/protobuf-java-3.20.3.ebuild
deleted file mode 100644
index 2e58b824d118..000000000000
--- a/dev-java/protobuf-java/protobuf-java-3.20.3.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 2008-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="com.google.protobuf:${PN}:${PV}"
-# Tests not enabled, depend on com.google.truth which is not packaged
-# https://github.com/protocolbuffers/protobuf/blob/v3.20.3/java/core/pom.xml#L35-L40
-# JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-PARENT_PN="${PN/-java/}"
-PARENT_PV="${PV}"
-PARENT_P="${PARENT_PN}-${PARENT_PV}"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/protocolbuffers/protobuf/archive/v${PARENT_PV}.tar.gz
- -> ${PARENT_P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-fi
-
-DESCRIPTION="Google's Protocol Buffers - Java bindings"
-HOMEPAGE="
- https://developers.google.com/protocol-buffers/
-"
-
-LICENSE="BSD"
-SLOT="0/31"
-
-S="${WORKDIR}/${PARENT_P}/java"
-
-BDEPEND="
- dev-libs/protobuf:${SLOT}
-"
-DEPEND="
- >=virtual/jdk-1.8:*
- test? (
- dev-java/guava:0
- dev-java/mockito:4
- )
-"
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-
-JAVA_AUTOMATIC_MODULE_NAME="com.google.protobuf"
-JAVA_JAR_FILENAME="protobuf.jar"
-JAVA_RESOURCE_DIRS="core/src/main/resources"
-JAVA_SRC_DIR="core/src/main/java"
-
-JAVA_TEST_GENTOO_CLASSPATH="guava,junit-4,mockito-4"
-JAVA_TEST_RESOURCE_DIRS="../src"
-JAVA_TEST_SRC_DIR="core/src/test/java"
-
-# Same than PATCHES but from repository's root directory,
-# please see function `src_prepare` below.
-# Simplier for users IMHO.
-PARENT_PATCHES=(
-)
-
-# Here for patches within "java/" subdirectory.
-PATCHES=(
-)
-
-src_prepare() {
- pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
- [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
- eapply_user
- popd > /dev/null || die
-
- # Remove bundled jars
- java-pkg_clean
-
- java-pkg-2_src_prepare
-
- # There is also compiler/plugin, but not in this list because in a subdirectory
- core_protos=( any api descriptor duration empty field_mask source_context struct timestamp type wrappers )
-
- # Copy resources from ../src/google/protobuf according to
- # https://github.com/protocolbuffers/protobuf/blob/v3.20.2/java/core/pom.xml#L45-L61
- mkdir -p "${JAVA_RESOURCE_DIRS}/google/protobuf/compiler" || die
- cp "../src/google/protobuf/${core_protos[@]}.proto" \
- "${JAVA_RESOURCE_DIRS}/google/protobuf" || die
- cp {../src,"${JAVA_RESOURCE_DIRS}"}/google/protobuf/compiler/plugin.proto || die
-
- # Generate 146 .java files according to
- # https://github.com/protocolbuffers/protobuf/blob/v3.20.3/java/core/generate-sources-build.xml
- for proto in "${core_protos[@]}" compiler/plugin; do
- "${BROOT}/usr/bin/protoc" \
- --java_out="${JAVA_SRC_DIR}" -I../src ../src/google/protobuf/"${proto}".proto || die
- done
-}