summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-04-26 12:08:58 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-28 11:13:47 +0200
commit0af2167b0d3b307418bff480a7a77f77deb0b338 (patch)
tree4946eae4a0bcc9400aa95ab5f26e646594ec578f /dev-java/randomized-runner/randomized-runner-2.7.8.ebuild
parentdev-java/jansi: switched to slot 0 + eapi7/java 1.8 in 1.11 (diff)
downloadgentoo-0af2167b0d3b307418bff480a7a77f77deb0b338.tar.gz
gentoo-0af2167b0d3b307418bff480a7a77f77deb0b338.tar.bz2
gentoo-0af2167b0d3b307418bff480a7a77f77deb0b338.zip
dev-java/randomized-runner: new package
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/20546/commits/c95e45533ccda1893234a2aaaf459f203d1b3a62 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/randomized-runner/randomized-runner-2.7.8.ebuild')
-rw-r--r--dev-java/randomized-runner/randomized-runner-2.7.8.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/randomized-runner/randomized-runner-2.7.8.ebuild b/dev-java/randomized-runner/randomized-runner-2.7.8.ebuild
new file mode 100644
index 000000000000..638cef4a653e
--- /dev/null
+++ b/dev-java/randomized-runner/randomized-runner-2.7.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/randomizedtesting/randomizedtesting/archive/refs/tags/release/2.7.8.tar.gz --slot 0 --keywords "~amd64 ~x86" --ebuild randomized-runner-2.7.8.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.8"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JUnit test runner and plugins for running JUnit tests with pseudo-randomness."
+HOMEPAGE="https://github.com/randomizedtesting/randomizedtesting/randomizedtesting-runner"
+SRC_URI="https://github.com/randomizedtesting/randomizedtesting/archive/refs/tags/release/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Common dependencies
+# POM: pom.xml
+# junit:junit:4.12 -> >=dev-java/junit-4.12:4
+
+CDEPEND="
+ >=dev-java/junit-4.12:4
+"
+
+# Compile dependencies
+# POM: pom.xml
+# test? org.assertj:assertj-core:2.2.0 -> >=dev-java/assertj-core-2.3.0:2
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ ${CDEPEND}
+ test? (
+ >=dev-java/assertj-core-2.3.0:2
+ )
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CDEPEND}"
+
+S="${WORKDIR}/randomizedtesting-release-${PV}/${PN}"
+
+JAVA_GENTOO_CLASSPATH="junit-4"
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="assertj-core-2"
+JAVA_TEST_SRC_DIR="src/test/java"