summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-04-19 12:57:16 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-19 12:57:38 +0200
commit18778345b809fd106fb1abf794a213a2e2a58309 (patch)
tree0f84e28530308b7dd16a50ab5688d9c53c3d7bef /dev-java/rat
parentdev-java/apache-rat-tasks: new package (diff)
downloadgentoo-18778345b809fd106fb1abf794a213a2e2a58309.tar.gz
gentoo-18778345b809fd106fb1abf794a213a2e2a58309.tar.bz2
gentoo-18778345b809fd106fb1abf794a213a2e2a58309.zip
dev-java/rat: bump to 0.13
Closes: https://bugs.gentoo.org/783819 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/rat')
-rw-r--r--dev-java/rat/rat-0.13.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/rat/rat-0.13.ebuild b/dev-java/rat/rat-0.13.ebuild
new file mode 100644
index 000000000000..ece22ac8b664
--- /dev/null
+++ b/dev-java/rat/rat-0.13.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2
+
+DESCRIPTION="Apache Rat is a release audit tool, focused on licenses."
+HOMEPAGE="https://creadur.apache.org/rat/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ ~dev-java/apache-rat-core-${PV}:0
+ ~dev-java/apache-rat-tasks-${PV}:0
+ >=virtual/jre-1.8:*
+"
+
+S="${WORKDIR}"
+
+src_compile() { :; }
+
+src_install() {
+ default
+ java-pkg_register-dependency apache-rat-core,apache-rat-tasks
+ java-pkg_dolauncher "apache-${PN}" --jar $(java-pkg_getjar apache-rat-core apache-rat-core.jar) --main org.apache.rat.Report
+}