summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-11-21 23:09:16 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-11-21 23:09:16 +0000
commit24754c8a26870665d33d9c18dc76d6d51fa32e04 (patch)
tree1a38ca64a9b91b688af091a60ba2260a777a4643 /dev-java/reflections/reflections-0.9.10-r1.ebuild
parentdev-util/checkstyle: Version bump to 7.2, EAPI bump to 6 (diff)
downloadgentoo-24754c8a26870665d33d9c18dc76d6d51fa32e04.tar.gz
gentoo-24754c8a26870665d33d9c18dc76d6d51fa32e04.tar.bz2
gentoo-24754c8a26870665d33d9c18dc76d6d51fa32e04.zip
dev-java/reflections: Use newer guava SLOT, EAPI bump to 6
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-java/reflections/reflections-0.9.10-r1.ebuild')
-rw-r--r--dev-java/reflections/reflections-0.9.10-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/reflections/reflections-0.9.10-r1.ebuild b/dev-java/reflections/reflections-0.9.10-r1.ebuild
new file mode 100644
index 000000000000..6cde882aef34
--- /dev/null
+++ b/dev-java/reflections/reflections-0.9.10-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java runtime metadata analysis"
+HOMEPAGE="https://github.com/ronmamo/reflections"
+SRC_URI="http://search.maven.org/remotecontent?filepath=org/${PN}/${PN}/${PV}/${P}-sources.jar"
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CP_DEPEND="dev-java/commons-vfs:2
+ dev-java/dom4j:1
+ dev-java/gson:2.6
+ dev-java/guava:20
+ dev-java/javassist:3
+ dev-java/jsr305:0
+ dev-java/slf4j-api:0
+ dev-java/tomcat-servlet-api:3.1"
+
+RDEPEND=">=virtual/jre-1.7
+ ${CP_DEPEND}"
+
+DEPEND=">=virtual/jdk-1.7
+ ${CP_DEPEND}
+ app-arch/unzip"