summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sablecc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sablecc')
-rw-r--r--dev-java/sablecc/Manifest2
-rw-r--r--dev-java/sablecc/files/sablecc2
-rw-r--r--dev-java/sablecc/metadata.xml8
-rw-r--r--dev-java/sablecc/sablecc-3.2.ebuild35
-rw-r--r--dev-java/sablecc/sablecc-3.7.ebuild35
5 files changed, 82 insertions, 0 deletions
diff --git a/dev-java/sablecc/Manifest b/dev-java/sablecc/Manifest
new file mode 100644
index 000000000000..c02d8b78422b
--- /dev/null
+++ b/dev-java/sablecc/Manifest
@@ -0,0 +1,2 @@
+DIST sablecc-3.2.tar.gz 440484 SHA256 f6a9e9ff5d2f57fa2c99f08653bb8c034fbd2de9e34aaf31b412c1b656fef80c SHA512 d8682a1cfd8bbb77543733008a12c4581c6b75c4e20a320d4dfc26b179e03076adfe735d70cc0ed92435ee23f6f74717524c800724f16804dc4d0078606918bd WHIRLPOOL db8aafe6134176091c7e173ed513d1acd61bd82767eadab788ada43de09645d975d213dd10626ee482b02c44372095470975854e52b23f23800aee9459aba251
+DIST sablecc-3.7.tar.gz 556985 SHA256 665e25207832246449dcd3e5d1fff4dec77b0db27378a3de528bca2ecbd680f0 SHA512 c53212ae10afc546796a46b8f1d731d3337c1fe184f12a285686b1f876b207a6cddcd789876d5c9d6b378583065bbb8ca7b5c3797d88b4eea3609ffe9a9c8f71 WHIRLPOOL bae77590d9a9afe017d0a797edfd1fe67b4fc099b4cc9bf654d57d3101d97f601cf4df849c28fbf0047ff888df2b285421fbc4556c942cb77da56ea07e7ab2ce
diff --git a/dev-java/sablecc/files/sablecc b/dev-java/sablecc/files/sablecc
new file mode 100644
index 000000000000..ec449013fa84
--- /dev/null
+++ b/dev-java/sablecc/files/sablecc
@@ -0,0 +1,2 @@
+#!/bin/sh
+${JAVA_HOME}/bin/java -jar /usr/share/sablecc/lib/sablecc.jar $*
diff --git a/dev-java/sablecc/metadata.xml b/dev-java/sablecc/metadata.xml
new file mode 100644
index 000000000000..6c817e87bfb4
--- /dev/null
+++ b/dev-java/sablecc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">sablecc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/sablecc/sablecc-3.2.ebuild b/dev-java/sablecc/sablecc-3.2.ebuild
new file mode 100644
index 000000000000..653f65d38d1c
--- /dev/null
+++ b/dev-java/sablecc/sablecc-3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java based compiler / parser generator"
+HOMEPAGE="http://www.sablecc.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4"
+
+src_unpack() {
+ unpack ${A}
+ rm -v "${S}"/lib/*.jar || die
+}
+
+JAVA_PKG_FILTER_COMPILER="jikes"
+
+src_install() {
+ java-pkg_dojar lib/*
+
+ dobin "${FILESDIR}"/${PN}
+
+ dodoc AUTHORS THANKS || die
+ dohtml README.html || die
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/sablecc/sablecc-3.7.ebuild b/dev-java/sablecc/sablecc-3.7.ebuild
new file mode 100644
index 000000000000..5b1b39afba07
--- /dev/null
+++ b/dev-java/sablecc/sablecc-3.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java based compiler / parser generator"
+HOMEPAGE="http://www.sablecc.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+java_prepare() {
+ rm -v "${S}"/lib/*.jar || die
+}
+
+src_install() {
+ java-pkg_dojar lib/*
+
+ dobin "${FILESDIR}"/${PN}
+
+ dodoc AUTHORS THANKS
+ dohtml README.html
+
+ use source && java-pkg_dosrc src/*
+}