summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/saxon/saxon-6.5.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/saxon/saxon-6.5.5.ebuild')
-rw-r--r--dev-java/saxon/saxon-6.5.5.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/saxon/saxon-6.5.5.ebuild b/dev-java/saxon/saxon-6.5.5.ebuild
new file mode 100644
index 000000000000..f9c7640612ff
--- /dev/null
+++ b/dev-java/saxon/saxon-6.5.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc examples source"
+inherit java-pkg-2 java-ant-2 eutils versionator
+
+MY_P="${PN}$(replace_all_version_separators -)"
+DESCRIPTION="A collection of tools for processing XML documents: XSLT processor, XSL library, parser"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+HOMEPAGE="http://saxon.sourceforge.net/"
+
+LICENSE="MPL-1.1"
+SLOT="6.5"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+COMMON_DEP="~dev-java/jdom-1.0"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+
+ unzip -qq source.zip -d src || die "failed to unpack"
+
+ cp "${FILESDIR}/build-${PV}.xml" build.xml || die
+
+ rm -v *.jar || die
+ rm -rf doc/api || die
+ rm samples/java/*.class || die
+ mkdir lib && cd lib
+ java-pkg_jar-from jdom-1.0
+}
+
+src_compile() {
+ java-pkg_filter-compiler jikes
+
+ eant -Dproject.name=${PN} jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ if use doc; then
+ java-pkg_dojavadoc dist/doc/api
+ dohtml -r doc/*
+ fi
+ use examples && java-pkg_doexamples samples
+ use source && java-pkg_dosrc src/*
+}