summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-01-13 21:54:29 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-01-13 22:00:59 +0000
commit06b877d738100fbf3444807eeeedb9cce409280e (patch)
tree50dc230662401d3fa8b3494b51ed4d427f5e38d4 /dev-java/snakeyaml/snakeyaml-1.16.ebuild
parentwww-client/chromium: dev channel bump (49.0.2618.8) (diff)
downloadgentoo-06b877d738100fbf3444807eeeedb9cce409280e.tar.gz
gentoo-06b877d738100fbf3444807eeeedb9cce409280e.tar.bz2
gentoo-06b877d738100fbf3444807eeeedb9cce409280e.zip
dev-java/snakeyaml: Version bump to 1.16
Now includes working tests. Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/snakeyaml/snakeyaml-1.16.ebuild')
-rw-r--r--dev-java/snakeyaml/snakeyaml-1.16.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/snakeyaml/snakeyaml-1.16.ebuild b/dev-java/snakeyaml/snakeyaml-1.16.ebuild
new file mode 100644
index 000000000000..cd31a3be8a66
--- /dev/null
+++ b/dev-java/snakeyaml/snakeyaml-1.16.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple vcs-snapshot
+
+DESCRIPTION="A YAML 1.1 parser and emitter for Java 5"
+HOMEPAGE="https://bitbucket.org/asomov/snakeyaml"
+SRC_URI="https://bitbucket.org/asomov/${PN}/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/joda-time:0
+ dev-java/junit:4 )"
+
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${P}"
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ # Remove some tests with tricky dependencies.
+ rm -rv src/test/java/{examples/SpringTest.java,org/yaml/snakeyaml/{emitter/template/VelocityTest.java,issues/issue9}} || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc README.md src/etc/announcement.msg
+}
+
+src_test() {
+ local DIR="src/test/java"
+ local CP="${DIR}/../resources:${DIR}:${PN}.jar:$(java-pkg_getjars joda-time,junit-4)"
+
+ local TESTS=$(find "${DIR}" -name "*Test.java" ! -name AbstractTest.java ! -name PyImportTest.java)
+ TESTS="${TESTS//src\/test\/java\/}"
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d "${DIR}" $(find "${DIR}" -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}