summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-05 14:06:45 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-05 15:56:41 +0000
commit2ed6bccad1bcb02e2779ddbf9bfafb7064b43f52 (patch)
treef9a8afb3afb9b2d409cfd0e88e82b790e6e334fc /dev-java/snip/snip-0.11-r1.ebuild
parentsys-boot/grub: amd64 stable wrt bug #575596 (diff)
downloadgentoo-2ed6bccad1bcb02e2779ddbf9bfafb7064b43f52.tar.gz
gentoo-2ed6bccad1bcb02e2779ddbf9bfafb7064b43f52.tar.bz2
gentoo-2ed6bccad1bcb02e2779ddbf9bfafb7064b43f52.zip
dev-java/snip: EAPI 5 bump. Switch to java-pkg-simple.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/snip/snip-0.11-r1.ebuild')
-rw-r--r--dev-java/snip/snip-0.11-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/snip/snip-0.11-r1.ebuild b/dev-java/snip/snip-0.11-r1.ebuild
new file mode 100644
index 000000000000..542052ea842b
--- /dev/null
+++ b/dev-java/snip/snip-0.11-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="an Apache ANT optional task that extracts snippets of code from text files"
+HOMEPAGE="http://www.martiansoftware.com/lab/snip.html"
+SRC_URI="http://www.martiansoftware.com/lab/${PN}/${P}-src.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+CDEPEND="dev-java/ant-core:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"
+
+JAVA_GENTOO_CLASSPATH="ant-core"
+
+java_prepare() {
+ java-pkg_clean
+}