summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/spin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/spin')
-rw-r--r--dev-java/spin/Manifest1
-rw-r--r--dev-java/spin/files/1.5-build.xml197
-rw-r--r--dev-java/spin/files/1.5-maven-build.properties16
-rw-r--r--dev-java/spin/metadata.xml8
-rw-r--r--dev-java/spin/spin-1.5-r1.ebuild49
5 files changed, 271 insertions, 0 deletions
diff --git a/dev-java/spin/Manifest b/dev-java/spin/Manifest
new file mode 100644
index 000000000000..0db00563c728
--- /dev/null
+++ b/dev-java/spin/Manifest
@@ -0,0 +1 @@
+DIST spin-1.5-all.zip 482286 SHA256 5515bb6b6724c856e94271bc3bd11fcc0170cf37835bf5fd93026b98c6bf3594 SHA512 ce1fad3b138781359d472727b186722d6f1f23b7002dd1ada294efd80b3a9caf5de15207cdd682fcbfcafa85c63895c7dd9683fefb5ce5b09cc4115ae3733466 WHIRLPOOL f5e598f01d923cdc202e776fddcefe34abb1a312b5ec9ba68f3745431faf89fb58d9ee233b62225bd1a549ec0829a13bea126e8a3802ec78a72f9dc6ef01eb88
diff --git a/dev-java/spin/files/1.5-build.xml b/dev-java/spin/files/1.5-build.xml
new file mode 100644
index 000000000000..ac58aec49131
--- /dev/null
+++ b/dev-java/spin/files/1.5-build.xml
@@ -0,0 +1,197 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 4/20/07 5:09 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="spin-from-maven" default="dist" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environnement properties -->
+ <!-- ====================================================================== -->
+
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="spin-1.5"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/java"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/main/java"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.settings.offline" value="true"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}" classpath="${gentoo.classpath}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.4"
+ verbose="false"
+ fork="false"
+ source="1.4">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <include name="**/*"/>
+ <exclude name="**/*.java"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="junit-present, compile"
+ description="Compile the test code"
+ if="junit.present">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}" classpath="${gentoo.classpath}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.4"
+ verbose="false"
+ fork="false"
+ source="1.4">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}">
+ <include name="**/*"/>
+ <exclude name="**/*.java"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="junit-present, compile-tests"
+ if="junit.present"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <pathelement path="${gentoo.classpath}"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*Test.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="junit-present"
+ depends="test-junit-present"
+ unless="junit.present">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> Junit isn&apos;t present in your $ANT_HOME/lib directory. Tests not executed. </echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Dist target -->
+ <!-- ====================================================================== -->
+
+ <target name="dist" depends="package,test" description="Package the application and run tests"/>
+</project> \ No newline at end of file
diff --git a/dev-java/spin/files/1.5-maven-build.properties b/dev-java/spin/files/1.5-maven-build.properties
new file mode 100644
index 000000000000..1d9c9b68034b
--- /dev/null
+++ b/dev-java/spin/files/1.5-maven-build.properties
@@ -0,0 +1,16 @@
+#Generated by Maven Ant Plugin - DO NOT EDIT THIS FILE!
+#Fri Apr 20 17:09:04 EEST 2007
+project.build.outputDirectory=${maven.build.outputDir}
+project.build.directory=${maven.build.dir}
+maven.test.reports=${maven.build.dir}/test-reports
+maven.build.finalName=spin-1.5
+maven.reporting.outputDirectory=${maven.build.dir}/site
+maven.build.testResourceDir.0=src/test/java
+maven.build.outputDir=${maven.build.dir}/classes
+maven.build.resourceDir.0=src/main/java
+maven.build.testOutputDir=${maven.build.dir}/test-classes
+maven.settings.offline=false
+maven.build.dir=target
+maven.settings.interactiveMode=true
+maven.build.testDir.0=src/test/java
+maven.build.srcDir.0=src/main/java
diff --git a/dev-java/spin/metadata.xml b/dev-java/spin/metadata.xml
new file mode 100644
index 000000000000..a15327b8ef8a
--- /dev/null
+++ b/dev-java/spin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">spin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/spin/spin-1.5-r1.ebuild b/dev-java/spin/spin-1.5-r1.ebuild
new file mode 100644
index 000000000000..c42dbb5fe212
--- /dev/null
+++ b/dev-java/spin/spin-1.5-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Transparent threading solution for non-freezing Swing applications"
+HOMEPAGE="http://spin.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}-all.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+COMMON_DEP="dev-java/cglib:3"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEP}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp "${FILESDIR}/${PV}-build.xml" build.xml || die
+ cp "${FILESDIR}/${PV}-maven-build.properties" maven-build.properties || die
+ rm -v lib/*.jar || die
+ java-pkg_filter-compiler jikes
+}
+
+EANT_GENTOO_CLASSPATH="cglib-3"
+
+# Needs X
+RESTRICT="test"
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}