summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-05-03 16:10:52 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-03 16:12:29 +0200
commit768542eb1a03dd9bec85bb2a038a710bb0c4b214 (patch)
tree15857b2098b93428b289c0058f130862068e9c11 /dev-java/stax2-api
parentdev-python/matplotlib: Switch to PEP517 build (diff)
downloadgentoo-768542eb1a03dd9bec85bb2a038a710bb0c4b214.tar.gz
gentoo-768542eb1a03dd9bec85bb2a038a710bb0c4b214.tar.bz2
gentoo-768542eb1a03dd9bec85bb2a038a710bb0c4b214.zip
dev-java/stax2-api: ensure that module-info.class is generated
Ensure that the resulting .jar contains the compiled module-info.java, i.e., module-info.class, by compiling with a JDK >= 9. Bug: https://bugs.gentoo.org/841785 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/stax2-api')
-rw-r--r--dev-java/stax2-api/stax2-api-4.2.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/stax2-api/stax2-api-4.2.1-r1.ebuild b/dev-java/stax2-api/stax2-api-4.2.1-r1.ebuild
new file mode 100644
index 000000000000..df7bba6a77cc
--- /dev/null
+++ b/dev-java/stax2-api/stax2-api-4.2.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/FasterXML/stax2-api/archive/refs/tags/stax2-api-4.2.1.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild stax2-api-4.2.1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.codehaus.woodstox:stax2-api:4.2.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="stax2 API is an extension to basic Stax 1.0 API"
+HOMEPAGE="https://github.com/FasterXML/stax2-api"
+SRC_URI="https://github.com/FasterXML/${PN}/archive/refs/tags/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.9:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( README.md release-notes/VERSION )
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_SRC_DIR=( "src/main/java" "src/moditect" )
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+src_install() {
+ default # https://bugs.gentoo.org/789582
+ java-pkg-simple_src_install
+}