summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sun-jaf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sun-jaf')
-rw-r--r--dev-java/sun-jaf/Manifest1
-rw-r--r--dev-java/sun-jaf/metadata.xml5
-rw-r--r--dev-java/sun-jaf/sun-jaf-1.1.1.ebuild40
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/sun-jaf/Manifest b/dev-java/sun-jaf/Manifest
new file mode 100644
index 000000000000..a1a273a87b0a
--- /dev/null
+++ b/dev-java/sun-jaf/Manifest
@@ -0,0 +1 @@
+DIST sun-jaf-1.1.1.tar.bz2 125305 SHA256 3c61b1390a92b0116c7c43434d1a81eedfcfed7b95017110ba0d9c9ee31b731d SHA512 c7287056514324aa5feeed3d4afaf861869974dd565f7810e0161fe590f070ec894e7005ffac4dd42cf075313237027d7d7c88cbf583e28e05df361536d73001 WHIRLPOOL 2f2fcb4c0b4f649ab6f42ffdf9075b11416e4a09f75760775055ed5dbf0c0a6a633f51738011f87b257dbe552e3aefaba1269ccc8e5fb4d23883432ea08e9856
diff --git a/dev-java/sun-jaf/metadata.xml b/dev-java/sun-jaf/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/sun-jaf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/sun-jaf/sun-jaf-1.1.1.ebuild b/dev-java/sun-jaf/sun-jaf-1.1.1.ebuild
new file mode 100644
index 000000000000..a217cc88da82
--- /dev/null
+++ b/dev-java/sun-jaf/sun-jaf-1.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Sun's JavaBeans Activation Framework (JAF)"
+HOMEPAGE="http://java.sun.com/products/javabeans/glasgow/jaf.html"
+# CVS:
+# View: https://glassfish.dev.java.net/source/browse/glassfish/activation/?only_with_tag=JAF-1_1
+# How-To: https://glassfish.dev.java.net/servlets/ProjectSource
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+# Remember to pray that bootstrap HEAD works
+#cvs -d:pserver:guest@cvs.dev.java.net:/cvs export -r JAF-${PV/./_} glassfish/activation
+#cvs -d:pserver:guest@cvs.dev.java.net:/cvs export -r HEAD glassfish/bootstrap
+#find . -name \*.jar -delete
+#tar cvjf ${P}.tar.bz glassfish
+#upload
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc source"
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+S="${WORKDIR}/glassfish/activation"
+
+JAVA_PKG_BSFIX="off"
+
+EANT_DOC_TARGET="docs"
+
+src_install() {
+ java-pkg_dojar build/release/activation.jar
+ use doc && java-pkg_dojavadoc build/release/docs/javadocs
+ use source && java-pkg_dosrc src/java
+}