summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sun-java3d-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sun-java3d-bin')
-rw-r--r--dev-java/sun-java3d-bin/Manifest4
-rw-r--r--dev-java/sun-java3d-bin/metadata.xml5
-rw-r--r--dev-java/sun-java3d-bin/sun-java3d-bin-1.3.2-r1.ebuild45
-rw-r--r--dev-java/sun-java3d-bin/sun-java3d-bin-1.4.0_pre5-r1.ebuild49
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-java/sun-java3d-bin/Manifest b/dev-java/sun-java3d-bin/Manifest
new file mode 100644
index 000000000000..5cf150a515d9
--- /dev/null
+++ b/dev-java/sun-java3d-bin/Manifest
@@ -0,0 +1,4 @@
+DIST java3d-1_3_2-linux-amd64.zip 1241855 SHA256 e248fc43792db5a351540e7c1a7c4c594fee30d5a8e622dbd8290075becca8a8
+DIST java3d-1_3_2-linux-i586.zip 1235329 SHA256 1fc3a02714bcfd938b5449561cee49c3ffe5f8c320591374caab4a0c2bb9f415
+DIST java3d-1_4_0-build5-linux-amd64.zip 1281828 SHA256 1ec9d7dc176eff6bf2c3568f452fc5b13d471d4f963090570996a635b8f8a301 SHA512 ec1074e5ad40964a80e2ec3332f67d1b7067db6aa5d99379f9e488e2c6a342b0c3d0c78aadd995bd647047efdeb0f040c8e8c7e4557a5161b6a8919fe93cff81 WHIRLPOOL 835257f8099a71cff3533a651d08af2f487ca79699e3e0165999d8b3dede75bed373a7b7f9dbf42070adce5aab87563a2338195a9b96fbf4130db16456434686
+DIST java3d-1_4_0-build5-linux-i586.zip 1274577 SHA256 e03d87159b4d2cecd48f90d1373dfc496049e41888e8a545cf5bfe94a89aa4ff
diff --git a/dev-java/sun-java3d-bin/metadata.xml b/dev-java/sun-java3d-bin/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/sun-java3d-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/sun-java3d-bin/sun-java3d-bin-1.3.2-r1.ebuild b/dev-java/sun-java3d-bin/sun-java3d-bin-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..40a626bf57f2
--- /dev/null
+++ b/dev-java/sun-java3d-bin/sun-java3d-bin-1.3.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+DESCRIPTION="Sun Java3D API Core"
+HOMEPAGE="https://j3d-core.dev.java.net/"
+SRC_URI="amd64? ( java3d-${PV//./_}-linux-amd64.zip )
+ x86? ( java3d-${PV//./_}-linux-i586.zip )"
+KEYWORDS="-* amd64 x86"
+SLOT="0"
+LICENSE="sun-jrl sun-jdl"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.3"
+RESTRICT="fetch"
+
+S=${WORKDIR}/${A/.zip/}
+
+pkg_nofetch() {
+ einfo "Please download java3d-${PV//./_}-linux-${ARCH/x86/i586}.zip from"
+ einfo "${HOMEPAGE} and place it in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unzip -q j3d-132-linux-${ARCH}.zip || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ dodoc COPYRIGHT.txt README.txt
+
+ java-pkg_dojar lib/ext/*.jar
+ java-pkg_doso lib/${ARCH/x86/i386}/*.so
+}
+
+pkg_postinst() {
+ elog "This ebuild installs into /opt/${PN} and /usr/share/${PN}"
+ elog 'To use you need to pass the following to java'
+ elog '-Djava.library.path=$(java-config -i sun-java3d-bin) -cp $(java-config -p sun-java3d-bin)'
+}
diff --git a/dev-java/sun-java3d-bin/sun-java3d-bin-1.4.0_pre5-r1.ebuild b/dev-java/sun-java3d-bin/sun-java3d-bin-1.4.0_pre5-r1.ebuild
new file mode 100644
index 000000000000..4ed500086eff
--- /dev/null
+++ b/dev-java/sun-java3d-bin/sun-java3d-bin-1.4.0_pre5-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+MY_PV=${PV//./_}
+MY_PV=${MY_PV//_pre/-build}
+MY_IPV=${MY_PV//_/}
+
+DESCRIPTION="Sun Java3D API Core"
+HOMEPAGE="https://j3d-core.dev.java.net/"
+SRC_URI="
+ amd64? (
+ http://download.java.net/media/java3d/builds/stable/${MY_PV}/java3d-${MY_PV}-linux-amd64.zip
+ )
+ x86? (
+ http://download.java.net/media/java3d/builds/stable/${MY_PV}/java3d-${MY_PV}-linux-i586.zip
+ )"
+KEYWORDS="-* amd64 x86"
+SLOT="0"
+LICENSE="sun-jrl sun-jdl"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/${A/.zip/}"
+ unzip -q j3d-${MY_IPV}-linux-${ARCH}.zip || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ cd "${WORKDIR}/${A/.zip/}"
+ dodoc COPYRIGHT.txt README.txt
+
+ java-pkg_dojar lib/ext/*.jar
+ java-pkg_doso lib/${ARCH/x86/i386}/*.so
+}
+
+pkg_postinst() {
+ elog "This ebuild installs into ${JAVA_PKG_LIBDEST} and ${JAVA_PKG_JARDEST}"
+ elog 'To use this when writing your own applications you can use for example:'
+ elog '-Djava.library.path=$(java-config -i sun-java3d-bin) -cp $(java-config -p sun-java3d-bin)'
+}