summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-02-14 14:46:34 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-02-15 09:36:01 +0100
commitcbba5a0807e0a0a88f2303f39329bcaa0433acad (patch)
tree8ad5d71158053d8333b3ce010c591f9fc83b6290 /dev-java/treelayout
parentmedia-video/droidcam: add version 1.8.2 (diff)
downloadgentoo-cbba5a0807e0a0a88f2303f39329bcaa0433acad.tar.gz
gentoo-cbba5a0807e0a0a88f2303f39329bcaa0433acad.tar.bz2
gentoo-cbba5a0807e0a0a88f2303f39329bcaa0433acad.zip
dev-java/treelayout: Switch to java-pkg-simple
Bug: https://bugs.gentoo.org/829354 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/treelayout')
-rw-r--r--dev-java/treelayout/treelayout-1.0.3-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/treelayout/treelayout-1.0.3-r1.ebuild b/dev-java/treelayout/treelayout-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..70635a92601c
--- /dev/null
+++ b/dev-java/treelayout/treelayout-1.0.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/abego/treelayout/archive/v1.0.3.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild treelayout-1.0.3-r1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.abego.treelayout:org.abego.treelayout.core:1.0.3"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Efficient and customizable TreeLayout Algorithm in Java."
+HOMEPAGE="https://github.com/abego/treelayout"
+SRC_URI="https://github.com/abego/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# LICENSE="!!!equivalentPortageLicenseName-not-found!!!"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+DOCS=( ../README.md )
+
+S="${WORKDIR}/${P}/org.abego.treelayout"
+
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+
+src_install() {
+ default # https://bugs.gentoo.org/789582
+ java-pkg-simple_src_install
+}