summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-07-12 10:10:48 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-24 19:00:51 +0200
commit38b683bdf0b36272979e5fe7a54da3903929843b (patch)
tree43c0e21b9cfc86c5bf89af544cc0600ad265a02e /dev-java/typesafe-config/typesafe-config-1.4.2.ebuild
parentdev-java/poi: add 5.2.2 (diff)
downloadgentoo-38b683bdf0b36272979e5fe7a54da3903929843b.tar.gz
gentoo-38b683bdf0b36272979e5fe7a54da3903929843b.tar.bz2
gentoo-38b683bdf0b36272979e5fe7a54da3903929843b.zip
dev-java/typesafe-config: add 1.4.2
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/26366 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/typesafe-config/typesafe-config-1.4.2.ebuild')
-rw-r--r--dev-java/typesafe-config/typesafe-config-1.4.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-java/typesafe-config/typesafe-config-1.4.2.ebuild b/dev-java/typesafe-config/typesafe-config-1.4.2.ebuild
new file mode 100644
index 000000000000..e9aedc5756a7
--- /dev/null
+++ b/dev-java/typesafe-config/typesafe-config-1.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="com.typesafe:config:1.4.2"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A library of arguably useful Java utilities"
+HOMEPAGE="https://lightbend.github.io/config/"
+SRC_URI="https://github.com/lightbend/config/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc source"
+
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*"
+
+DOCS=( {CONTRIBUTING,HOCON,NEWS,README}.md )
+
+S="${WORKDIR}/config-${PV}"
+
+JAVA_SRC_DIR="config/src/main/java"
+# https://github.com/lightbend/config/blob/v1.4.2/build.sbt#L104
+JAVA_AUTOMATIC_MODULE_NAME="typesafe.config"
+
+# Need to anylyze what to do with this stuff
+JAVA_TEST_SRC_DIR="config/src/test/java"
+JAVA_TEST_RESOURCE_DIRS="config/src/test/resources"