summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/xml-commons-external/xml-commons-external-1.3.04.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/xml-commons-external/xml-commons-external-1.3.04.ebuild')
-rw-r--r--dev-java/xml-commons-external/xml-commons-external-1.3.04.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/xml-commons-external/xml-commons-external-1.3.04.ebuild b/dev-java/xml-commons-external/xml-commons-external-1.3.04.ebuild
new file mode 100644
index 000000000000..33818c5b7649
--- /dev/null
+++ b/dev-java/xml-commons-external/xml-commons-external-1.3.04.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="An Apache-hosted set of externally-defined standards interfaces, namely DOM, SAX, and JAXP"
+HOMEPAGE="http://xml.apache.org/commons/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+# upstream source tar.gz is missing build.xml and other stuff, so we get it like this
+# svn export http://svn.apache.org/repos/asf/xml/commons/tags/xml-commons-external-1_3_04/java/external/ xml-commons-external-1.3.04
+# tar cjf xml-commons-external-1.3.04.tar.bz2 xml-commons-external-1.3.04
+
+LICENSE="Apache-2.0"
+SLOT="1.3"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc source"
+
+DEPEND=">=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+
+src_install() {
+ java-pkg_dojar build/xml-apis.jar build/xml-apis-ext.jar
+
+ dodoc NOTICE README.* || die
+
+ if use doc; then
+ java-pkg_dojavadoc build/docs/javadoc
+ java-pkg_dohtml -r build/docs/dom
+ fi
+ use source && java-pkg_dosrc src/javax src/org
+}