summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-07-20 21:45:05 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-07-20 21:45:05 +0200
commit01881f349f8420f045a164bdd7762fac0f7142c2 (patch)
tree9f1b9c25a27cc8efb61c2759234fbd114f363cda /dev-java
parentapp-eselect/eselect-vi: version bump. (diff)
downloadgentoo-01881f349f8420f045a164bdd7762fac0f7142c2.tar.gz
gentoo-01881f349f8420f045a164bdd7762fac0f7142c2.tar.bz2
gentoo-01881f349f8420f045a164bdd7762fac0f7142c2.zip
dev-java/java-config: clean up old.
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-config/Manifest1
-rw-r--r--dev-java/java-config/files/java-config-2.2.0-prefix.patch15
-rw-r--r--dev-java/java-config/files/java-config-2.2.0-py38.patch52
-rw-r--r--dev-java/java-config/java-config-2.2.0-r4.ebuild44
4 files changed, 0 insertions, 112 deletions
diff --git a/dev-java/java-config/Manifest b/dev-java/java-config/Manifest
index f75ce7c90ed0..9cc9cc4e6e3a 100644
--- a/dev-java/java-config/Manifest
+++ b/dev-java/java-config/Manifest
@@ -1,2 +1 @@
-DIST java-config-2.2.0.tar.bz2 51851 BLAKE2B 7b7c15dc988d2f5f54ebacba224f57193577e24f99a798657b40d83d723280562e314ba71319958a83be44defc6a48ac1114cce37eaeddea025ea31f26cf331a SHA512 a491cfe86bde8afadfc5b875740d79f9077526d8650ffb034fdad67a7ffa1b02646f67b1ef0eab7b0fe3ae57b5d767fa6a0d5593fe07416993d60588a8ed595a
DIST java-config-2.3.1.tar.gz 26165 BLAKE2B 948506663513db369d0ed8ffdfaa54c643989431430ea03440551a6a4b6725d8eec38f5cb4fde3b64e8936c0f43de0e65a7368469032c646c7b6b3bb7ec3ed13 SHA512 62db555b2d8a37a03b6a03aa133010848d54be33ba6e3c43807abefe665a9d8ff2790baf1af79b98d4a7bd3e9ba6bc64382a24c3fcf7038338123dabd146b7b4
diff --git a/dev-java/java-config/files/java-config-2.2.0-prefix.patch b/dev-java/java-config/files/java-config-2.2.0-prefix.patch
deleted file mode 100644
index 068538a69f91..000000000000
--- a/dev-java/java-config/files/java-config-2.2.0-prefix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Wait for the java team to upstream this patch.
-Bug: 591156
---- /setup.py 2013-02-15 07:12:09.000000000 +0900
-+++ /setup.py.new 2016-08-13 16:38:22.000000000 +0900
-@@ -87,8 +87,8 @@
- elif arch in ['hpux']:
- defaults = '*= hp-jdk-bin'
-
-- os.mkdir(self.root + '/usr/share/java-config-2/config/')
-- with open(self.root + '/usr/share/java-config-2/config/jdk-defaults.conf', 'w') as f:
-+ os.mkdir(self.root + eprefix + '/usr/share/java-config-2/config/')
-+ with open(self.root + eprefix + '/usr/share/java-config-2/config/jdk-defaults.conf', 'w') as f:
- f.write("# This files contain the default support jdk's\n")
- f.write(defaults + "\n")
-
diff --git a/dev-java/java-config/files/java-config-2.2.0-py38.patch b/dev-java/java-config/files/java-config-2.2.0-py38.patch
deleted file mode 100644
index cb59e1f36be1..000000000000
--- a/dev-java/java-config/files/java-config-2.2.0-py38.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 5e7cc49184e657bd446998f4b08e9106e5215ce5 Mon Sep 17 00:00:00 2001
-From: Georgy Yakovlev <gyakovlev@gentoo.org>
-Date: Thu, 7 May 2020 02:45:57 -0700
-Subject: [PATCH] replace is with ==
-
----
- src/java-config-2 | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/java-config-2 b/src/java-config-2
-index 8ad2539..84ecd30 100755
---- a/src/java-config-2
-+++ b/src/java-config-2
-@@ -199,7 +199,7 @@ def set_user_vm(option, opt, value, parser):
- if not vm:
- fatalError("Could not find a vm matching: %s" % value)
- else:
-- if os.getuid() is 0:
-+ if os.getuid() == 0:
- fatalError("The user 'root' should always use the System VM")
- else:
- try:
-@@ -227,7 +227,7 @@ def user_classpath_target():
- # Deprecated
- def set_system_classpath(option, opt, value, parser):
- deprecation_notice()
-- if os.getuid() is 0:
-+ if os.getuid() == 0:
- pkgs = value.split(',')
- manager.set_classpath(system_classpath_target(), pkgs)
-
-@@ -252,7 +252,7 @@ def set_user_classpath(option, opt, value, parser):
- # Deprecated
- def append_system_classpath(option, opt, value, parser):
- deprecation_notice()
-- if os.getuid() is 0:
-+ if os.getuid() == 0:
- pkgs = value.split(',')
- manager.append_classpath(system_classpath_target(), pkgs)
-
-@@ -277,7 +277,7 @@ def append_user_classpath(option, opt, value, parser):
- # Deprecated
- def clean_system_classpath(option, opt, value, parser):
- deprecation_notice()
-- if os.getuid() is 0:
-+ if os.getuid() == 0:
- manager.clean_classpath(system_classpath_target())
- update_env()
- else:
---
-2.26.2
-
diff --git a/dev-java/java-config/java-config-2.2.0-r4.ebuild b/dev-java/java-config/java-config-2.2.0-r4.ebuild
deleted file mode 100644
index 8f03a425121d..000000000000
--- a/dev-java/java-config/java-config-2.2.0-r4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# jython depends on java-config, so don't add it or things will break
-PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1
-
-DESCRIPTION="Java environment configuration query tool"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
-SRC_URI="https://dev.gentoo.org/~gyakovlev/distfiles/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( sys-apps/portage[${PYTHON_USEDEP}] )"
-
-# baselayout-java is added as a dep till it can be added to eclass.
-RDEPEND="
- !dev-java/java-config-wrapper
- sys-apps/baselayout-java
- sys-apps/portage[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.0-prefix.patch
- "${FILESDIR}"/${PN}-2.2.0-py38.patch
-)
-
-python_install_all() {
- distutils-r1_python_install_all
-
- # This replaces the file installed by java-config-wrapper.
- dosym java-config-2 /usr/bin/java-config
-}
-
-python_test() {
- esetup.py test
-}