summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-01-20 22:36:08 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-20 22:46:08 +0100
commit160385f7ce834c6af506de6cebe5cb0d9a599165 (patch)
tree9e0ae364197884fe96a0df69d542a444adb2135f /dev-java
parentdev-java/jgoodies-forms: stable for amd64. mark stable for the remaining arch... (diff)
downloadgentoo-160385f7ce834c6af506de6cebe5cb0d9a599165.tar.gz
gentoo-160385f7ce834c6af506de6cebe5cb0d9a599165.tar.bz2
gentoo-160385f7ce834c6af506de6cebe5cb0d9a599165.zip
dev-java/jgoodies-forms: clean up old.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild b/dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild
deleted file mode 100644
index b43552d93c73..000000000000
--- a/dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-JAVA_PKG_IUSE="doc examples source"
-
-inherit java-pkg-2 java-ant-2 eutils
-
-MY_PN="forms"
-MY_PV=${PV//./_}
-MY_P="${MY_PN}-${MY_PV}"
-DESCRIPTION="JGoodies Forms Library"
-HOMEPAGE="http://www.jgoodies.com/"
-SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc64 x86 ~x86-fbsd ~x64-macos"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.4
- app-arch/unzip"
-RDEPEND=">=virtual/jre-1.4"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_unpack() {
- unpack ${A} || die "Unpack failed"
- cd "${S}"
-
- # Remove the packaged jars
- rm -v *.jar || die "rm failed"
-}
-
-src_compile() {
- # it does not like unset ${build.compiler.executable}
- # feel free to fix if you want jikes back
- java-pkg_filter-compiler jikes
- # not setting the bootcp breaks ecj, javac apparently ignores nonsense
- eant -Dbuild.boot.classpath="$(java-config -g BOOTCLASSPATH)" jar
-}
-
-#Needs X
-#src_test() {
-# ANT_TASKS="ant-junit" eant test \
-# -Djunit.jar="$(java-pkg_getjars junit)"
-#}
-
-src_install() {
- java-pkg_dojar build/${MY_PN}.jar
-
- dodoc RELEASE-NOTES.txt README.html || die
-
- use doc && java-pkg_dohtml -r docs/*
- use source && java-pkg_dosrc src/{core,extras}/com
- use examples && java-pkg_doexamples src/tutorial
-}