summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-06-12 23:33:59 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-06-12 23:34:17 +0200
commit2b992c70ddf14f7e296dc52103b898e1700f0307 (patch)
tree708c4e30237f2940d1a606868753df6cf48b9cd5 /dev-java
parentdev-java/laf-plugin: clean up old. (diff)
downloadgentoo-2b992c70ddf14f7e296dc52103b898e1700f0307.tar.gz
gentoo-2b992c70ddf14f7e296dc52103b898e1700f0307.tar.bz2
gentoo-2b992c70ddf14f7e296dc52103b898e1700f0307.zip
dev-java/glassfish-transaction-api: EAPI 6 bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/glassfish-transaction-api/glassfish-transaction-api-1.1.2.2.04-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/glassfish-transaction-api/glassfish-transaction-api-1.1.2.2.04-r1.ebuild b/dev-java/glassfish-transaction-api/glassfish-transaction-api-1.1.2.2.04-r1.ebuild
new file mode 100644
index 000000000000..e9fe920b6327
--- /dev/null
+++ b/dev-java/glassfish-transaction-api/glassfish-transaction-api-1.1.2.2.04-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit versionator java-pkg-2 java-pkg-simple
+
+MAJOR=v$(get_version_component_range 3-4)
+MAJOR=$(replace_version_separator 1 ur ${MAJOR})
+MY_PV=${MAJOR}-b$(get_version_component_range 5)
+MY_PN=${PN/-//}
+ZIP="glassfish-${MY_PV}-src.zip"
+
+DESCRIPTION="Java Transaction API"
+HOMEPAGE="https://glassfish.dev.java.net/"
+
+SRC_URI="http://download.java.net/javaee5/${MAJOR}/promoted/source/${ZIP}"
+
+LICENSE="|| ( CDDL GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ default
+ unzip \
+ -q -o -f \
+ "${DISTDIR}/${ZIP}" \
+ "${MY_PN}/*" "glassfish/bootstrap/*" || die "unpacking failed"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+}