summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-10-21 20:33:05 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-10-21 20:35:43 +0100
commit3d16aaaa8d4a7b0de9316374a0c222a7d94000ea (patch)
tree503ce0257d1505f9deacb0ac130766db6eebc7e3 /dev-java
parentsci-calculators/units: Version 2.18 (diff)
downloadgentoo-3d16aaaa8d4a7b0de9316374a0c222a7d94000ea.tar.gz
gentoo-3d16aaaa8d4a7b0de9316374a0c222a7d94000ea.tar.bz2
gentoo-3d16aaaa8d4a7b0de9316374a0c222a7d94000ea.zip
dev-java/icedtea: Reintroduce stack alignment fix for x86
This is still not addressed upstream. Bug: https://bugs.gentoo.org/647954 Signed-off-by: James Le Cuirot <chewi@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea/icedtea-3.9.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-java/icedtea/icedtea-3.9.0.ebuild b/dev-java/icedtea/icedtea-3.9.0.ebuild
index cec602924898..ef84f38c763b 100644
--- a/dev-java/icedtea/icedtea-3.9.0.ebuild
+++ b/dev-java/icedtea/icedtea-3.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
@@ -6,7 +6,7 @@
EAPI="6"
SLOT="8"
-inherit check-reqs gnome2-utils java-pkg-2 java-vm-2 multiprocessing pax-utils prefix versionator
+inherit check-reqs flag-o-matic gnome2-utils java-pkg-2 java-vm-2 multiprocessing pax-utils prefix versionator
ICEDTEA_VER=$(get_version_component_range 1-3)
ICEDTEA_BRANCH=$(get_version_component_range 1-2)
@@ -224,6 +224,9 @@ src_configure() {
# In-tree JIT ports are available for amd64, arm, arm64, ppc64 (be&le), SPARC and x86.
if { use amd64 || use arm || use arm64 || use ppc64 || use sparc || use x86; }; then
hotspot_port="yes"
+
+ # Work around stack alignment issue, bug #647954.
+ use x86 && append-flags -mincoming-stack-boundary=2
fi
# Always use HotSpot as the primary VM if available. #389521 #368669 #357633 ...